[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree864.01, G4, Ati Rage Pro 128 & Apple Studio 17"

> If I understand correctly, when I boot with
> append="video=aty128fb:vmode:20,cmode=32"
> in my yaboot.conf, the aty128fb driver will be communicating directly with
> my graphics hardware. When I then start X using the fbdev driver, the modes
> available to X are limited by the modes available to aty128fb.

No, at least not if you mean the modes in /etc/fb.modes . X should be able to
use any mode through aty128fb if it can without.

Ok. Even so, using aty128fb I should (assuming I find the right timings and add them to my fb.modes) be able to fbset to a 1600x1200 mode, right?

> (--) r128(0): Virtual Size is 1600x1200 (pitch 1600)
> (**) r128(0): Mode "1600x1200@60x": 162.0 MHz, 75.0 MHz, 60.0 Hz
> So, alter Xf86Config firstly to use Mode "1600x1200@65x" which causes the
> screen to go blank.
> Reboot, look at /var/log/XFree86.0.log which is identical except for:
> (--) r128(0): Virtual Size is 1600x1200 (pitch 1600)
> (**) r128(0): Mode "1600x1200@65x": 175.5 MHz, 81.2 MHz, 65.0 Hz
> Both of these last two attempts did flash up a mangled image of the X
> display for a fraction of a second before going blank.

This is strange. It accepts the modes, but they don't get displayed?

yup, exactly :-)

Which depth are you trying? If possible, try using lower depths.

just tried 16 bit depth and 8 bit depth - no difference.

I also changed back to using aty128fb, changed the cmode down to 16, rebooted and tried fbset-ing to different modes - no difference. Interestingly (maybe?) I can't fbset to lower resolution modes either - it seems that if I use aty128fb I can only use 1280x1024; if i use the OFfb I can get a 1600x1200 console but still need to run X in 1280x1024.

I wonder if its the monitor that's causing the problem? According to the specs at the Apple site:


The HSync can only operate at 80 kHz. If I change my XF86Config to reflect this then *all* the 1600x1200 modes get deleted with HSync out of range. Yet OS9 / OSX can both operate at that resolution. I've searched for XF86Config files designed for this monitor, eg


but using this config and starting X causes my mac to emit one long beep, go blank and lock up. Rebooting and looking at the /var/log/XFree86.0.log tells me that the last thing X did before dieing was:

(II) FBDev(0): Checking Modes against framebuffer device...

Thanks again,


Reply to: