[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem booting from sda during installation



On Fri, Oct 06, 2000 at 02:40:18PM -0700, Indraneel Majumdar wrote:
> On Thu, 5 Oct 2000, Ethan Benson wrote:
> 
> > i am not entire sure what the 8550 is, like i said, try ofpath it may
> > already support that machine.
> > 
> 
> (the kernel is at sda2 in usual potato location with symlink)
> this is what ofpath gives when I run ofpath /dev/sda2:
> /bandit/gc/mesh/sd@0:2
> 
> I did:
> 
> nvsetenv boot-device /bandit/gc/mesh/sd@0:2
> (I also tried with these:
> /bandit/gc/mesh/sd@0
> /bandit/gc/mesh/sd@0:2\\vmlinux )

you want to use 

/bandit/gc/mesh/sd@0:2

or the more common method:

/bandit/gc/mesh/sd@0:0

the partition 0 trick makes OF load the boot block from the partition
marked bootable, which is your root partition, so it really should not
make any difference

> nvsetenv showed that the entries were updated. On rebooting it again
> stopped at blank screen. I noticed however that the starting music played
> twice (previously it was playing only once)

hmm... not sure why it would reboot itself..

> Do I need to run quik again after all this? I tried with and without
> running quik, it didn't work. Also I am running ofpath directly after
> booting from floppy. But I am running nvsetenv after doing chroot /target

that should be ok...  it never hurts to rerun quik if you change things..

> 
> What do I have to put in the nvsetenv line? All the bandit stuff or scsi?
> Will I have to put the kernel image location?

nvsetenv boot-device '/bandit/gc/mesh/sd@0:0'

be sure to quote it, the shell sometimes does not care for @ in the
command line...

one other thing you should try if you have not already is:

nvsetenv input-device keyboard
nvsetenv output-device screen

if you still don't see anything but a black screen then you need a
serial terminal to see OF, (you have to reset those back to normal for
that to work again) if you have any other machine around and can
connect the serial ports together and use a terminal emulater you can
access OF and see better what is happening.

one other thing, you will probably need to use at least the final
2.2.17 kernel (from ftp.kernel.org) the debian kernels are older and
may not work.  

also, make sure in your quik.conf that your image= line points to a
real kernel and not a symlink, for some reason quik does not work
reliably with symlinks.

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpkZEiY0Y59U.pgp
Description: PGP signature


Reply to: