[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: yaboot errors on g4



On Sat, Apr 08, 2000 at 03:21:51PM +1000, Brendan J Simon wrote:
> I've managed to yaboot to work from a zip disk and install the debian base2_2.tgz.
> I still have to boot into OF and type "boot zip:,yaboot" but at least it works.
> I deleted the Linux_PPC partitions and recreated them with pdisk.  I also got rid of the 2T of extra
> space on the hard disk that pdisk was reporting.  I did not reinitialise the partition table because I
> have data on the partitions at the moment.  I recopied the yaboot files to /dev/hda2 using mkofboot but

i really think you are going to have to reinitialize the partition
table to fix this problem, the full size of the disk is stored in the
partition table, and right now its wrong, very wrong.

> it still can't read the config file.  I will try changing hd:,\\yaboot to hd:,yaboot and see if that
> makes any difference.
> I'm getting there slowly.  I have managed to break to a terminal and do an apt-get update so hopefully
> this might fix some installation problems.

i would really reccommend repartitinging the disk before you get much
else done, i don't see this problem going away with a corrupt
partition table.  (that seems risky to me anyway, for filesystem health)

> Thanks for all your help and I will inform you of my results.
> Brendan Simon.
> 

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpW4m0FKpkcw.pgp
Description: PGP signature


Reply to: