[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Wrong filesystem for resc1440.bin

Hello Nathan,

It worked! The Debian installer started as you said it would do. But, when
it comes to the section: "Install Operating System Kernel and Modules", the
dbootstrap is unable to mount the Rescue Floppy.
The error message I get is:

Mount /dev/loop0 (type ext2) on /floppy: wrong filesystem type, or bad
superblock on/dev/loop0
Unable to mount the Rescue Floppy.

It seems like the dbootstrap program assume that the Rescue Floppy has an
ext2 filesystem. I tried to mount the resc1440.bin file with:

mount -o loop resc1440.bin /instmnt

and, the Rescue Floppy was mounted as msdos filesystem. Is this correct?
However, to go on with the installation I will try to convert the Rescue
Floppy to ext2 filesystem, as dbootstrap wants to have it that way. Has
anyone any better idea?

BTW, it's a Power Macintosh 8600/250.

Please answer me directly at christian.ericsson@bigfoot.com (I'm not
currently subscriber of this mailing list!)


At 23:00 1999-11-08 -0800, you wrote:
>Hey Christian,
>I myself am currently working my way through the installation process with
>my iMac. You didn't specify your system, but you might find the following
>page helpful:
>By the way, on older PMacs, you probably can use root1440.bin to get into
>the Debian installer directly. Rename root1440.bin "ramdisk.image.gz" and
>place it in your system folder. Put BootX in with your control panels and
>the BootX extension in your extensions folder. Get
>ftp://ftp.yellowdoglinux.com/pub/yellowdog/imaclinux/boot/vmlinux.gz and
>place the uncompressed vmlinux file in the "Kernals" folder that comes with
>BootX and put that in your system folder too.
>Reboot. When BootX comes up, check the boxes "ramdisk" and "no video
>driver" and write "ramdisk_size=8192 panic=20" in the "kernal arguments"
>line. Select Linux.
>You may or may not get the Linux dbootstrap installer to work. If you
>don't, you can always boot into the bash shell by adding "init=/bin/sh" to
>your kernal arguments in BootX. Visit the link at the top of this message
>if dbootstrap doesn't work.
>Good luck.
>Nathan Olsen
>"It is our nature to put all knowledge into context in order to tell
>a story, and to re-create the world by this means."
>                     --Edward O. Wilson, _Consilience_

Reply to: