[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: An BIG request for people that will working on powerpc packages!!

On Mon, Feb 22, 1999 at 01:44:23PM +0100, Sven LUTHER wrote:
> if i understood correctly, you are autobuilding packages with
> glibc2.1, while every other debian/ppc user has older versions of
> lgibc arround ? does it not cause problem ? 

   I was attempting to install Debian-PPC on a coworkers' G3 Mac today and
had problems.  Eventually what I had to do was "ar xv/tar xf data.tar.gz"
the libc6, tar, fileutils, and dpkg packages, and then atomically copy those
directories over the top of the previous system. libc6 2.0.100 broke the
other 3 packages if installed first (preventing further installs), while if
the other three packages were unpacked first they would fail to operate
under the old libc6.  There was only one missing symbol in all cases, and it
appears to have been created specifically to break compatibility.  Perhaps
an interim library with both the 2.0/2.1 versions of this symbol can be
produced, allowing older dpkg and related utilities to run on top of the new
   [ Shortly after passing this hurdle the entire disk was corrupted.  We'll
be trying a new disk tomorrow, so any feedback on installation would still
be helpful.  He wanted a Mac *and* Linux.  No pity.  :) ]


Reply to: