[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: buildd and virtual (build) dependencies :(((

On Fri, Jan 03, 2003 at 04:01:33PM +0100, Jérôme Marant wrote:
> En réponse à Sven Luther <luther@dpt-info.u-strasbg.fr>:
> > > None of the solution are the Right Thing. The Right
> > > Thing is versioned provides and it does not exist
> > > currently.
> > 
> > That also is not right. I thinnk something more on the line of
> > providing
> > both a version and a API version or something like that, or playing
> > more
> > tricks with the version number, or even having the posibility to say
> > that it is ok if the version is a subset of 3.06.1, that is all of
> >, 3.06.1-1, etc. Which would be enough for us.
> Well, sometimes it isn't. For example, when some ocaml is
> buggy, you need to change the virtual provides, so
> packages need to be rebuilt against it.
> With versioned provides, you don't need to rebuild all the
> time since you have version comparisons.

Huh ???

Basically what i say is that you could do a dependency for a range of
versions (as we did with 3.06 and 3.06-1) and bump this range when there
is an incompatible change which forces us to bump the version number.

> > > > I would much prefer fixing the auto-builders.
> > > > 
> > > > BTW, do anyone know where the auto-builder source code is located.
> > > 
> > > Sven, when James does not answer questions personally, the best
> > > way to get an answer is to bring the problem publicaly on
> > > debian-devel: someone will probably answer, give better
> > > solutions and there are chances that James decide to answer
> > > publicaly. I really advice you to do so.
> > 
> > Well, i did write a second mail a day after the first, and got an
> > _immediate_ response. It was not a good response though, so i think i
> > screwed us on this one. I apologized immediately for sounding hastive
> > or
> > rude, though, but still, ...
> So you have no more clues? Time to go for debian-devel then.

Well, i believe that all the problems is because of the mistake i did
with 3.06-13/14, and installing 3.06-15 on the arm box should solve the
problem. The only other problem is that the buildd should reschedule all
those built that failed because ocaml was not yet there to fullfill
these dependencies.

If there is something else, i cannot infere it from the build logs. 

I asked Jones Lamont, which had the same problem on december 24 on the
hppa builds, if he did see something else.

If i don't get further info by the end of next week, i will ask
elsewhere, maybe on debian-devel as you suggest, but i will not do this
before having waited enough time and informed myself a bit more.


Sven Luther
> --
> Jérôme Marant <jerome@marant.org>
>               <jerome.marant@free.fr>
> http://marant.org
> -- 
> To UNSUBSCRIBE, email to debian-ocaml-maint-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: