[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: versioned libraries dependencies

Sven Luther <luther@dpt-info.u-strasbg.fr> writes:

>>   Yes I understood correctly. But it is not necessary to make it mandatory
>>   since it really depends on applications. Those which are source compatible
>>   won't require it.
> Err, ... it is about libraries, not applications. And the idea is to
> bump the virtual provide version when an incompatibility is added. I
> know you will know that the current version is source compatible with
> the previous one, but how can you now it will be source compatible with
> the next version ? 

  When building a new version of the application depending on the
  said library. So, the -dev packages don't need such trick.

> Also, i am not entirely sure that source compatibility is enough in this
> case, not sure though.

  However, after thinking a bit more, the non-dev packages may need
  a version number in the package name, because of .so files.
  We are not sure about binary compatibily are we?

Jérôme Marant


Reply to: