[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: versioned libraries dependencies

Sven Luther <luther@dpt-info.u-strasbg.fr> writes:

>> Sorry, I do not understand what needs to be added to the policy.
>> Do you want to add an explaination on how to work out the dependency
>> problems you described?
> Jerome, i think you misunderstood, what he wants is not to do a :
> depend: ocamlnet (>= 4.5.6), ocamlnet (<4.5.7)
> but to use a virtual package like ocaml does, that is ocamlnet 4.5.6
> would :
> provide: ocamlnet-4.5.6.
> And what would be in the policy would be an explanation, plus some text
> making this mandatory to be policy compliant.

  Yes I understood correctly. But it is not necessary to make it mandatory
  since it really depends on applications. Those which are source compatible
  won't require it.


Jérôme Marant


Reply to: