[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [jdamour@nycap.rr.com: Re: Please help sorting out which sid updates need to make sarge]



Jeroen van Wolffelaar wrote:
> packages in contrib are allowed to FTBFS due to missing dependencies in
> Debian. You may close any FTBFS bugs on filler caused by missing java2
I think this should be missing *build*-dependencies.
To me it looks like filler 1.02-2 specifies java-compiler, debhelper as
build-dependencies.
While it's certainly OK for contrib packages to have build-dependencies
outside Debian, it's my understanding that the build-dependencies need
to be specified properly. Here, the package claims to be compilable by
any java compiler, that includes gcj.
My apologies for taking the mail initially forwarded to -mentors as an
indication of a more complicated problem and suggesting asking for the
removal of the package. If it's really just that bug, you might just
want to clarify the build-depenency.

Kind regards

Thomas
-- 
Thomas Viehmann, <http://thomas.viehmann.net/>

Attachment: pgpkiOHJG6yD6.pgp
Description: PGP signature


Reply to: