[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [MoM] Packaging fis-get

On Sun, Jan 29, 2012 at 06:14:29PM -0500, Bhaskar, K.S wrote:

> >So, when I install fis-gtm 5.3-017g today and next week
> >Debian delivers a package containing the code for 5.5-000
> >will there be a way for me to upgrade my database/M code ?
> >If so, then I fail to see the problem with Debian providing
> >the new GT.M version to me via a package ?  And later
> >providing me with a 5.6-002z package allowing me to run,
> >say,
> >
> >	/sbin/fis-gtm-upgrade
> [KSB]  Yes, that's the general idea.  But it's a little more
> complicated than that because, for example, you may want to build new
> shared libraries for the code, and occasionally other configuration
> files may need to be tweaked or extended.

Absolutely. Just like with any other Debian package.

Let me try to derive the most basic question again so we can
perhaps find an answer:

- VistA runs on Mumps.

- GT.M provides a Mumps environment

- GT.M is written in Mumps and thusly needs to be compiled
  by a Mumps compiler

- this presents a chicken-egg problem in that Debian does
  not allow packages to be included without compiling them
  from source

- the easy way out would be if

1) there existed a Mumps compiler written in C/C++/Pascal/...
2) which is compatible with the DFSG
3) which can - however deficiently - compile GT.M

So, is there ?

GPG key ID E4071346 @ gpg-keyserver.de
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

Reply to: