[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrad removed packages

On Mon, Aug 08, 2005 at 01:01:46AM -0600, Bob Proulx wrote:
> > I ran aptitude dist-upgrade and was using mozilla at the same time.
> > Mozilla vanished off the screen and then I noticed an error from
> > aptitude in the xterm window.  Then the my CPU monitor went to 100%
> > and the system would not respond.
> > 
> > I never had that happen before.
> That sounds like some glitch happened such as filling up your disk to
> 100% which caused cascade failures.

This laptop has only one partition.  (Well, the other 8GB isn't
mounted right now.)

moseley@laptop:~$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda4              12G  9.7G  2.0G  84% /

which is after downloading all the new packages.  Not a lot of free
space, but seems like enough.

> >     bash: /bin/ls : Input/ouptut error
> Because of the spelling error I assume you typed that in instead of
> cutting and pasting.

I couldn't cut-n-paste because the machine is unusable at that point.

> But if 'ls' is reporting an I/O error that does
> not bode well.  Check your /var/log/syslog for errors.  You may have a
> disk drive crash.  I/O errors usually means a drive gone bad.  Which
> would make sense during an upgrade because you would be touching disk
> blocks that you would not normally touch.  Those blocks may have been
> bad for a while and you would not have noticed until you tried to read
> and modify them.

Well, I was going to argue against a disk failure.  For one thing I
can't find anything unusual in any of my logs.  Second, the laptop seems
to work fine -- except when I try and run apt-get or aptitude and it
finally locks up with the Input/output error message.  I'm using the
laptop now -- and it's running quite a bit and just finished running
the daily updatedb to stressed the hard drive quite a bit.

But, when I first booted this morning and started mutt and read your
mail I went to look at logs again and didn't see anything odd, but it
did finally lockup with that Input/output error for every command I
tried to use.  So maybe the disk is failing so fast that there's no
time to write to the disk.

Still, that doesn't make sense.  I can consistently make it fail by
running apt-get and aptitude, but otherwise the laptop boots and
seems to work ok (except for that first boot this morning).

I'm living on borrowed time with this laptop, regardless.

> I would boot off of a live cdrom such as a knoppix disk.  Then you
> could run diagnostics against the disk.  If you are getting I/O errors
> then I would make sure you have all of the data you need off of the
> disk while you still can.  Some drives work in that mode with bad
> blocks for a long time.  Others die off very quickly.  It is hard to
> predict.  (I should take a picture of a big stack of dead drives next
> to my desk from years of collecting them.)

Yes, maybe time for a clean install and a new drive.  I wonder if
knoppix has the smartmontools installed (and if this drive will work
with SMART).  I've been meaning to play with SMART for a while.

> Good luck!

Thanks, looks like I'll need it.

Bill Moseley

Reply to: