[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrad removed packages

Bill Moseley wrote:
> dbarker@turing.cs.camosun.bc.ca wrote:
> > But for some reason, it insisted on removing kmail. This wasn't a big
> > deal, because she'd abandoned kmail for thunderbird over a year ago,
> > but occasionally she wants to use it.
> > 
> > However, immediately after the dist-upgrade I did an apt-get install
> > kmail which worked perfectly. So obviously no broken/unment
> > dependencies.

I have seen that too with other packages.  Almost always this is with
KDE packages though.  I can't remember seeing it with any other

For one point though is that from last year you had installed a sarge
release candidate snapshot.  There is no official testing of upgrades
from random snapshots to the released version.  Only from released
woody to released sarge and in the future from released sarge to the
released etch.  So there very might well have been a problem with the
kde packages you had had installed on the machine from last year.

I think KDE packages trigger this problem so much because they have a
complex set of dependencies.  In particular I believe complex this OR
that relationships cause this problem.  It creates multiple stable
states and apt does not know how to choose.  We don't notice when apt
chooses the way we want.  But we do notice when apt choices in ways
that we do not want.

> Either that or the original dist-upgrade was confused about broken
> packages -- and the actual upgrade clear up the confusion.  But,
> it's things like that which make me want more details about why
> apt-get or aptitude are removing a package.

At one time I remember someone posting a way to get aptitude to print
out debug statements about why it wanted to install and remove various
packages.  (I think it was on the debian-amd64 list though.)  However
I have lost that posting and have been unable to find it.  I would
really like to know how to debug these dependency issues further.
Mostly I just remove kde packages and then reinstall them later as you

> And my dist-upgrade today, well, it didn't go so well.  Looks like my
> package system is destroyed.
> I ran aptitude dist-upgrade and was using mozilla at the same time.
> Mozilla vanished off the screen and then I noticed an error from
> aptitude in the xterm window.  Then the my CPU monitor went to 100%
> and the system would not respond.
> I never had that happen before.

That sounds like some glitch happened such as filling up your disk to
100% which caused cascade failures.

> Now trying to re-run aptitude I get:
>     Preconfiguring packages ...
>     dpkg-query: parse error, in file `/var/lib/dpkg/available' near line 1:
>      EOF after field name `'
>     dpkg: --compare-versions takes three arguments: <version> <relation> <version>
>     ...
>     Ack!  Something bad happened while installing packages.  Trying to recover:
>     dpkg: parse error, in file `/var/lib/dpkg/available' near line 1:
>      EOF after field name `'

That sounds like either a full disk or a disk error.

> Tried a few other things like removing /var/lib/dpkg/available and
> also restoring from "available-old" and keep getting some error that
> finally results in a "bash" prompt where NOTHING works on the system.
> Try running any command (like ls) and it says:
>     bash: /bin/ls : Input/ouptut error

Because of the spelling error I assume you typed that in instead of
cutting and pasting.  But if 'ls' is reporting an I/O error that does
not bode well.  Check your /var/log/syslog for errors.  You may have a
disk drive crash.  I/O errors usually means a drive gone bad.  Which
would make sense during an upgrade because you would be touching disk
blocks that you would not normally touch.  Those blocks may have been
bad for a while and you would not have noticed until you tried to read
and modify them.

> Mutt was still open and then it complained it couldn't open a file in
> /tmp -- and then it died.
> Any suggestions on how to try and get the package system working
> again?
>     $ dpkg --get-selections
>     dpkg: parse error, in file `/var/lib/dpkg/available' near line 1:
>      EOF after field name `'
> I have a bad feeling about this...

I have the feeling that you will be replacing the disk drive soon.
This all makes sense if it is a drive problem.  Check /var/log/syslog
and see what errors are logged there.

I would boot off of a live cdrom such as a knoppix disk.  Then you
could run diagnostics against the disk.  If you are getting I/O errors
then I would make sure you have all of the data you need off of the
disk while you still can.  Some drives work in that mode with bad
blocks for a long time.  Others die off very quickly.  It is hard to
predict.  (I should take a picture of a big stack of dead drives next
to my desk from years of collecting them.)

Good luck!


Attachment: signature.asc
Description: Digital signature

Reply to: