[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dist-upgrad removed packages

On Sun, Aug 07, 2005 at 11:17:44AM -0700, dbarker@turing.cs.camosun.bc.ca wrote:
> Thus spake Frans Pop (aragorn@tiscali.nl):
> But for some reason, it insisted on removing kmail. This wasn't a big
> deal, because she'd abandoned kmail for thunderbird over a year ago,
> but occasionally she wants to use it.
> However, immediately after the dist-upgrade I did an apt-get install
> kmail which worked perfectly. So obviously no broken/unment
> dependencies.

Either that or the original dist-upgrade was confused about broken
packages -- and the actual upgrade clear up the confusion.  But,
it's things like that which make me want more details about why
apt-get or aptitude are removing a package.

And my dist-upgrade today, well, it didn't go so well.  Looks like my
package system is destroyed.

I ran aptitude dist-upgrade and was using mozilla at the same time.
Mozilla vanished off the screen and then I noticed an error from
aptitude in the xterm window.  Then the my CPU monitor went to 100%
and the system would not respond.

I never had that happen before.

Now trying to re-run aptitude I get:

    Preconfiguring packages ...
    dpkg-query: parse error, in file `/var/lib/dpkg/available' near line 1:
     EOF after field name `'
    dpkg: --compare-versions takes three arguments: <version> <relation> <version>
    Ack!  Something bad happened while installing packages.  Trying to recover:
    dpkg: parse error, in file `/var/lib/dpkg/available' near line 1:
     EOF after field name `'

Tried a few other things like removing /var/lib/dpkg/available and
also restoring from "available-old" and keep getting some error that
finally results in a "bash" prompt where NOTHING works on the system.
Try running any command (like ls) and it says:

    bash: /bin/ls : Input/ouptut error

Mutt was still open and then it complained it couldn't open a file in
/tmp -- and then it died.

Any suggestions on how to try and get the package system working

    $ dpkg --get-selections
    dpkg: parse error, in file `/var/lib/dpkg/available' near line 1:
     EOF after field name `'

I have a bad feeling about this...

Bill Moseley

Reply to: