[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gdm fails

Hi Aswin,

On Wed, 2003-10-22 at 17:55, Aswin Venkat wrote:
> Hi all-

> As Jaume suggested in an earlier email, i tried reconfiguring the
> xserver--after playing around with some of the drivers, i used the vesa driver(though my
> video card is actua
> lly ATI Tech-Radeon) with 24dpi and a high monitor resolution as the
> default(though the manufacturer puts my monitors at 1024x768--i
> found that using this resolution created a wide black border) i was able to
> get gnome to work. I read in some website that Radeon is only supported by
> Xfree86-4.3 and onwards, mine is Xfree86-4.1. Has anybody dealt with
> this problem?. If that is indeed the case, can i use apt to upgrade
> it or are there other things that have to be taken care of?
The black border results from the fact that your laptop's BIOS doesn't
stretch the smaller 1024x768 image to the maximum possible size of the
screen. BTW, it would look nasty if it did so, since it would use some
sort of interpolation to stretch it. Result would be sort of a "unsharp"

To get XFree 4.3, you don't have to upgrade to unstable or testing.
Simply use backports.

Here is my /etc/apt/sources.list, containing all that you will probably
need to get XFree 4.3, Gnome 2.2 and some other updated stuff. For me,
that all works very well. Observe the comments below.

--- snip ---
#### this is woody himself
deb http://ftp.de.debian.org/debian stable main contrib non-free
deb http://ftp.de.debian.org/debian-non-US stable/non-US  main contrib
#### and some security updates
deb http://security.debian.org stable/updates main contrib non-free

#### XFree 4.3 backport
#### this should work as of today (2003-10-22), delivers 4.3.0
deb http://people.debian.org/~mmagallo/packages/xfree86/i386/ ./
#### I got my XFree 4.3 from the  ximian-desktop 2 project, but at 
##### this time the server kicks me on connect.
#### TRY OUT by uncommenting below two lines
#deb ftp://linux.upsa.es/pub/RC2/ ./
#deb ftp://linux.upsa.es/pub/OO.O/ ./

#### Gnome 2.2 backport to woody, including evolution 1.4.5
http://ftp.acc.umu.se/mirror/mirrors.evilgeniuses.org.uk/debian/backports/woody gnome2.2/
http://ftp.acc.umu.se/mirror/mirrors.evilgeniuses.org.uk/debian/backports/woody gnome2.2/

##### MPlayer 
 deb http://marillat.free.fr stable main

##### Mozilla 1.4
 deb http://debian.relativ.org/ ./

#### official sources
# deb-src http://ftp.debian.org/debian stable main contrib non-free
# deb-src http://ftp.de.debian.org/debian-non-US stable/non-US main
contrib non-free

--- snap ---

Good luck


> The other problem that i'm facing right now is that i can't get my
> network connection working. I have a charter cable link at home. Can somebody help me with commands that
> can assist in configuring the network?. 
>  > 
>  > In Sid, I currently have X & KDE working fine.  After installing the base
>  > Sid, I installed a basic gnome, cause someone suggested I use gdm (did
>  > you mean gdm, or gmd?) as the logon window manager.  After that worked, I
>  > installed KDE, and set gdm (gnome desktop manager) to choose KDE as the
>  > desktop when the user logs in.
> Sorry, typo there--i meant gdm. Does Sid refer to the testing or the
> unstable debian distribution. 
>  > 
>  > I found gpm (general purpose mouse driver ?) was causing KDE to not start
>  > after I added it, so I've had to remove that (other higher priorities,
>  > currently, than finding the fix to that) even though I would like it
>  > installed.
>  > 
> I experienced the same problem while trying to get X to run. I am not
> sure how to fix it. 
> Thanks,
> Aswin
L@rs-W dot DE

Reply to: