[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dell latitude C810

Ok, i have an Inspiron 8100 and had some problems, too.

After Kernel 2.4..2 the notebook hung when i tried to suspend it, tired to 
plug/unplug AC power when i left it untouched for some time (then the apmd 
daemon tried to suspend it. The same happened when i tried to change the 
screen size (not the resolution) with the key-combo Fn-Font (just to zoom the 
screen to the full LCD-Display size, no matter if i tried this in X or on the 
console). Then i searched the net and found the problem:

You have to compile the kernel without "Local APIC Support on uniprocesors" 
and without it's suboption (obviously). This seems to be a general problem as 
i understand and no Dell specific one.

Then APM/ACPI runs again.

BTW, I had my discussions with Dell-Service and they told me that they _DO_ 
support Linux - but only Redhat and only in the USA. If you are no standard 
customer but a company customer and bought your notebook inside the USA then 
you have the option to get it with RedHat Linux installed on your notebook - 
and they give support for that! That's why i bought it because it knew that i 
could get everything to run on my notebook :)

So much for that.

Try to compile your kernel WITHOUT APIC support and you will have no problems 
- ok not that many. But for APM/ACPI - that's not the problem.

I have some problems, too:

With kernel 2.4.2 i had no problem suspending - but after kernel 2.4.8 i 
can't suspend. Why? Good question - this is what i read when i try to suspend 
at the console (inside X nothing happened):

smc-ircc, Suspending
nv_kern_pm event: rqst 0x0 data 0x3
NVRM: avoiding suspend resuest, don't want to shutdown!!
ircc_net_open(), unable to allocate DMA=3
smc-ircc, Waking up
NETDEV WATCHDOG: irda0: transmit timed out
irda0: transmit timed out

I don't know how to solve this by now. There's nothing in the NVidia docs.

And i have another Problem that i'll put in another thread.

Hope this helps and hope someone can help :)


Reply to: