[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: thinkpad600e/networkcard

Alexander Clouter <alexander.clouter@ic.ac.uk> writes:

> Thomas Vogels [tov@ece.cmu.edu] wrote:
> > 
> > I have that card (netgear FA511) and failed to get it to work.  The
> > card costs about $60 but to get it to work would be priceless...
> > 
> > I use woody, kernel 2.4.14 (for xfs) and the latest pcmcia-cs (from unstable)
> > along with tulip 1.1.8.  When I insert the card, I get an error
> > message about no IRQ known for Pin A.  
> > 
> > Oddly, I get a similar error message on another machine (desktop with
> > netgear 10/100 card), but the nic works.
> > 
> > What configuration do you use?  
> > Does anybody know how to solve this IRQ issue (on a TP 600)?
> > 
> well to get the card working I needed to add an entry to /etc/pcmcia/config
> ------
> card "NetGear FA511C Fast Ethernet"
>   pci 0x1317, 0x1985
>   bind "tulip_cb"
> ------
> this should be added near the other netgear (FA510C) cards for consistancy.

I put that info into a separate file, 'netgear.conf', which
/etc/pcmcia/config reads in.  This way, changes don't get lost with
upgrades of pcmcia-cs.

I see that you use tulip_cb.  So do you use
 -- the tulip_cb from pcmcia-modules?
 -- tulip_cb that came on the cdrom?
 -- tulip_cb from the scyld.com/networking web site?

What modules get loaded?  Just 'tulip_cb' and 'cb_enabler'?

> However this won't fix your problem.  My money is on you needing to edit
> /etc/pcmcia/config.opts to tell pcmcia-cs to stop using some of the probably
> already in use IRQ's (find from 'cat /proc/interupts').

The exact error message comes from the kernel:
 Linux Tulip driver version 1.1.8 (June 16, 2001)
 PCI: No IRQ known for interrupt pin A of device

and then:
 tulip: : I/O region (0x0@0x0) too small, aborting

I wonder why the kernel can't find an IRQ for the card.  Is this a bug
in the PCI code?

> However do you use the kernel pcmcia drivers or the pcmcia-cs pcmcia drivers,
> if you can understand what I'm trying to say :)  I every now and again try to
> get the kernel drivers working *properly* and all I can get them to do is
> only work when I insert-remove-insert the card.  The card has to be put in
> twice before it is noticed!  If I don't use the kernel drivers there is no
> problem.

I started out with the kernel drivers which support my linksys card
jsut find.  When I tried to add the latest tulip driver I got tons of
unresolved symbols so I must have been doing something wrong when
compiling it.

> If you are having more problems send me a copy of the output of 'dmesg' and
> /proc/interupts, /proc/ioports and anything else you like.
> As for the XFS.....GOOD MAN :)  None of that 'girly-man' reiserfs crud :)
> I'm running it too and everything is just peachy :)

And already needed it twice because I tried 'hotplug' support which
froze the system (dead cold and no hot plug whatsoever ;-)


> Alex
> BTW my card is actually a FA510C but my flatmate has a tp770x and a FA511C
> and it works great (except for a small bug which is probably tp
> related...but thats another story), the card runs fine on my laptop :)

I wanted to buy the FA510C but could only get my hands on the FA511C...

mailto:tov@ece.cmu.edu (Tom Vogels)   Tel: (412) 268-6638   FAX: -3204

Reply to: