[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mouse Problems, updated

> > I have a Compaq LTE5300 laptop on which I installed Debian 2.2r3. I
> > installed about 750MB or so of software, including XFree86, KDE 2.1, GNOME,
> > and others. It was a pretty standard install, using apt-get via http. My
> > mouse (a PS/2 pin-type pointing device) worked fine in console, using gpm,
> > but never worked in X. It would move, but so fast I could not see it, and
> > when I left it alone, would show up in the extreme left-hand corner of the
> > screen. I did a test where I killed the gpm server and ran XF86Setup, where
> > after I configured the mouse, it actually worked in XF86Setup. However, When
> > I typed in "startx" in console after the test (did not reboot), the system
> > booted into X, then GNOME, and the mouse worked not at all...  just a arrow
> > in the middle of my screen. When I first start the machine, KDE starts, not
> > GNOME...  I just tab my way to "Shutdown/Console Mode" to get to Runlevel 3
> > (the console) so I can actually do anything. I am at a loss at this point. I
> > read through every HOWTO, Mini-HOWTO, man page, and book I have, all to no
> > avail. I am afraid the my choices are one of two at this point:

1. Getting around:

You can switch to your six virtual consoles at any time with
ctrl-alt-F1 through ctrl-alt-F6.  You can get back to X with
ctrl-alt-F7.  You can shut down X with ctrl-alt-backspace
(but if you are running xdm or gdm they will just start it
right back up).

2. Fixing the mouse:

Edit your /etc/X11/XF86Config and then restart X and see if
it works.  If you have gpm (console mouse support) running 
and it's interfering, stop it (/etc/init.d/gpm stop), then
restart X and try that.  (Of course, don't use /dev/gpmdata 
in this mode, duh)

You may be tempted to uninstall everything and start over, a
very Windows solution ;-)  .  But I do understand and
recommend the go slow approach.  I myself have installed
Debian in cookie-jar mode (ooh, that looks cool, let me
install that too, and that one too, and cool, that too) and
I ended up with lots and lots of apps I never use, much less
understand.  But apt-get and dselect are so efficient you might 
as well install the 'maybe' apps later and keep your
/usr/doc small (so the docs you need are handy) and your
/etc small (again, so it's easy to find the file you are
looking for), keep the number of running daemons down, etc.

That said,  ...

> > 1) uninstall X, gpm, KDE, GNOME and re-install just X, and KDE (I hate
> > GNOME, I don't know how it got installed)

> should be able to just uninstall gnome, dpkg -l '*gnome*' would be a good start for the list of gnome packages.

3. [If you really want to] Uninstalling all X stuff:
3a. identify your X server: dpkg -l 'xserver*'
3b. simulate ininstalling it : 
  apt-get --simulate remove (your server pkg here)
3c. if you concur that you really want to remove all the
packages it lists, repeat without --simulate

> > 2) wipe out the entire Debian installation and start over from scratch,
> > installing each package at a time
> doh, sounds like too much work to me...

> > Can I remove some or all of this stuff with apt-get (just like this:
> > "apt-get remove (or uninstall) gpm)? I admit that the apt-get menu is very
> > daunting to me, as there is very little help with it. I cannot even tell how
> > to move back to the main screen after selecting something in a lower screen.

> apt-get doesn't have a menu as far as i have used it, what are you using, aptitude maybe?  the apt-get remove <packagename> line you mentioned works though, but i usually use aptitude to queue up a bunch of package downloads or removals to save on typing package names.

This will show you what that would do:
  apt-get --simulate remove gpm 
It will not get rid of X but will get gpm out of the way.
You can just shut down gpm till next reboot with /etc/init.d/gpm stop

Hope this helps


Reply to: