[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: x configuration on sony vaio

amael wrote:
> > > okay...it didn't work at first so i installed some more packages and
> > > eventually tried XF86Setup and it basically worked fine (messed up
> screen
> > > though) so i used my config file instead -- didn't work. so i ran
> XF86Setup
> > > again, this time trying to more or less reproduce my old config file
> with
> > > that setup program, and this time i even got a nice screen and a good
> > > resolution. anyway, when i run startx it doesn't work either. the
> problem is
> > > with X because i get the following output when i run either X or startx:
> > >
> > > var: allowed_users, value: rootonly.
> > > var: nice_value, value: -10.

I did a bit of looking as I had some problems when I install as well.

First, when you run XF86Setup you should save the file to
/etc/X11/XF86Config. There is a symbolic link from
/usr/X11R6/lib/X11/XF86Config to that file. The setup program defaults
in the the save dialog to the symlink.

Also, you shouldn't have to do weird things like copy files around and
such on Debian. The whole dpkg, apt approach is so you don't have to do
this. So I would try to undo anything abnormal if you can. BTW, I've
been using SuSE and have one box to switch to Debian.

The first line of the /etc/X11/XF86Config file should be
/usr/X11R6/bin/XF86_XXXX where I assume you should have SVGA for XXXX.
The rest of the file on my box is as follows

These are the choices

I'm running Gnome so I installed gdm(gnome display manager) as the
default on install is xdm and twm for the window manager. I also decided
to install icewm to run instead of twm but twm will work.
apt-get install gdm
later you can install icewm or sawmill or whatever. apt-get install

Also nothing worked until I rebooted and I got wierd can't open display
messages when gdm was not installed or was not running.

Also since I didn't pick the svga server during install, I had to do the
apt-get install xserver-svga

You can also do a dpkg -l to list what is installed. Overall, I think
Debian rules -- not released before it's time(at least stable).

Hope this helps,
Eric :-)

Reply to: