[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: x configuration on sony vaio

> > okay...it didn't work at first so i installed some more packages and
> > eventually tried XF86Setup and it basically worked fine (messed up
> > though) so i used my config file instead -- didn't work. so i ran
> > again, this time trying to more or less reproduce my old config file
> > that setup program, and this time i even got a nice screen and a good
> > resolution. anyway, when i run startx it doesn't work either. the
problem is
> > with X because i get the following output when i run either X or startx:
> >
> > var: allowed_users, value: rootonly.
> > var: nice_value, value: -10.
> It looks like it is asking you to be logged in as root to startx. You
> can also do something like the following to capture the output of
> startx.
> startx > x.txt 2>&1
> Hope this helps,
> eric :-)

hmmm, alright, i did this again. startx produces the following output (as

var: allowed_users, value: rootonly.
var: nice_value, value: -10.
X: cannot stat /etc/X11/X (No such file or directory), aborting.
giving up.
xinit: Connection refused (errno111): unable to connect to X server.
xinit: No such process (errno3): Server error.

now, i know that X is in /usr/bin/X11 so if i copy it to /etc/X11/ my output
is basically the first two lines of the above output, repeated infinitly.

as i said, XF86Setup manages to start X in svga and everything seems okay,
but if i start it manually (either as normal user or root) it doesn't work.

thanks for your time!


Reply to: