[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: making udev require 2.6.15 kernels

On Fri, Feb 10, 2006 at 04:20:02PM -0800, Steve Langasek wrote:
> This means you're not guaranteed to get /usr/sbin/sshd, which many admins
> use exclusively for system administration where remote kvm is not an
> affordable option.  That's a pretty big problem.

Maybe we need a sshd in /sbin then, since as i understand there is no real
guarantee that /usr is mounted always in case of problems ? 

> The stated problem is that upgrades from sarge to etch require the user to
> go to a bunch of extra work to change out their kernel before they can
> dist-upgrade.  I haven't heard you say "lvm will depend on the linux-image
> package it needs", or anything equivalent, which means the preinst check for
> running kernel version is the only protection against a completely broken
> system.

Yeah, all that is the same problem, and we need to find a way of fixing it
before the sarge release.

Maybe generalizing the --supported-version used by the ramdisk-generator tools
would be an idea.


Sven Luther

Reply to: