[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Digikam and phonon-backend-vlc (was: Re: Digikam 4:2.9.0-2 rebuild for Wheezy/Sid)

To readers on debian-kde: please drop CC to bug report if your answer does 
not add new test results or information.

Am Montag, 17. September 2012 schrieb Martin Steigerwald:
> Am Mittwoch, 12. September 2012 schrieb Detlev Brodowski:
> > Am Montag, 10. September 2012, 11:46:39 schrieb Martin Steigerwald:
> > > Hi Mark, hi Debian Qt/KDE developers,
> > > 
> > > any chance to upload Digikam 4:2.9.0-2 against libmarblewidet13?
> […]
> > Hi Mark, hi Debian Qt/KDE developers, hi Martin,
> > 
> > I'm using a pur sid installation as rolling release on my notebook.
> > So I have rebuilded the packages against an up to date sid repository
> > for my own. Furthermore I have removed, in my own build, the new
> > added conflict to the package phonon-backend-vlc because I could not
> > reproduce the bug #684130 neither with the 2.7.0 nor 2.9.0 debian
> > package from the experimental repository rebuilded for sid.
> > Tested with the vlc packages from main and from
> > debian-multimedia.org.
> Mark, thanks for uploading a new package which works with
> libmarblewidet13.
> I tried installing it but as Detlev points out it conflicts with
> phonon- backend-vlc due to bug 684130.
> Thus I will test the package the conflict removed here as well and
> report back. I hope that the conflict can be removed again.

I did so.

Digikam works nicely:

I can start digikam, browse pictures and view movie files. No crash.

I am using the following packages:

martin@merkaba:~> apt-show-versions | egrep "(phonon|digikam|alsa-|vlc)" | 
grep -v dbg
alsa-base/sid uptodate 1.0.25+2+nmu2
alsa-utils/sid uptodate 1.0.25-3
digikam/experimental upgradeable from 4:2.9.0-3~test to 4:2.9.0-3
digikam-data/experimental upgradeable from 4:2.9.0-3~test to 4:2.9.0-3
digikam-doc/experimental upgradeable from 4:2.9.0-3~test to 4:2.9.0-3
libphonon-dev/sid uptodate 4:
libphonon4/sid uptodate 4:
libvlc5/sid uptodate 2.0.3-2
libvlccore5/sid uptodate 2.0.3-2
phonon/sid uptodate 4:
phonon-backend-gstreamer/sid uptodate 4:
phonon-backend-vlc/sid uptodate 0.6.0-1
vlc/sid uptodate 2.0.3-2
vlc-data/sid uptodate 2.0.3-2
vlc-nox/sid uptodate 2.0.3-2
vlc-plugin-notify/sid uptodate 2.0.3-2
vlc-plugin-pulse/sid uptodate 2.0.3-2

together with a self-compiled 3.6-rc6 kernel on Debian Sid as of today.

I am uploading my (non chroot) 64 bit Digikam builds to for others to 


Please consider removing the conflict to phonon-backend-vlc now that 
neither Detlev nor Daniel nor me can reproduce the crash on start.

Dear Grey, please double check whether you have any deb-multimedia VLC 
packages installed and check your VLC installation.

As to the references Andreas Tille posted:

- With the Amarok won´t start issue there were indeed deb-multimedia.org 
packages involved:


- The second reference according to the reporter was with the original 

Still given the mixed picture and three reports of no issues whatsoever I 
kindly ask to remove the conflict so that the underlying bug can be fixed if 
any still exists.

If need be I will ask around at debian-kde for others to test the Digikam 
packages I uploaded with phonon-backend-vlc. Readers from debian-kde feel 
free to test my package builds and report your results. (No warranties 
whatsoever, these are just unclean non chroot builds which may carry more 
dependencies than necessary.)

Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7

Reply to: