[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dependency problems with Sound.

On Monday 17 January 2005 21:40, Tim Folger wrote:
> On Monday 17 January 2005 06:44 am, Alan Chandler wrote:
> > Its probably my fault for using the kde packages from
> >
> > http://pkg-kde.alioth.debian.org/kde-3.3.2 ./
> >
> > BUT ...
> >
> > system notifications which were ogg files would not play, so I am
> > attempting to do an upgrade of my debian unstable system.
> >
> > There seems to be a new "libflac6" attempting to be installed,
> > which k3b needs, and which conflicts with libflac4.  This conflict
> > is attempting to remove libflac4 and most of kde-multimedia.
> >
> > Any way round this?
> > --
> > Alan Chandler
> I had exactly the same problem. I finally solved it by manually
> installing the kde-multimedia upgrade (apt-get update, then apt-get
> install kde-multimedia). After that I was able to install the
> remaining upgrades with the normal apt-get upgrade command without
> removing all of kde. Once all the upgrades were installed, I had to
> delete two files (knotify.eventsrc and knotifyrc) from
> ~/.kde/share/config. When I restarted kde I had system sounds back as
> a normal user. I hope this works for you, too.

I tried all of this, but now I can't install several of the kdemultimedia 
packages because they depend on libflac4 and it doesn't exist.

Alan Chandler
First they ignore you, then they laugh at you,
 then they fight you, then you win. --Gandhi

Reply to: