[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install kde in Sid fails - depends libkmid... - How fix?



On Sun, Feb 17, 2002 at 02:53:51PM -0800, tluxt2@yahoo.com wrote:
> 
[snip]
> OK, I tried what you suggested and found the same problem as you found. 
> Here are some questions:
> 
> 1)  Is there some way to tell "apt-get install kde" to just install
> whatever it can, and ignore any unmet dependency problems?  (This would
> save me a _lot_ of extra learning & work right now, which is an acceptable
> tradeoff to me at this point, knowing some things will not be fully
> installed.)
Not as far as I know, but you could look at dependencies of KDE,
perhaps write a script to do that.

> 
> 
> 2)  Is there a way to set up apt to automatically & safely solve problems
> of this kind?  Perhaps by using the following 'default release' procedure?
>  
> [Hmm, my guess is that this probably won't solve this problem. :( ]
> 
>     create the file /etc/apt/apt.conf
>     and put in it only the following line:
>       APT::Default-Release "testing";]
> 
>   And, to install a package do:
>     apt-get install <package>/unstable
>   [in my case:
>     apt-get install kde/unstable]
> 
> 
> 3)  How do I find ("track down") a copy of the correct package?
> I couldn't find "libglib" at:
> http://204.152.189.120/debian/pool/main/libg/
> 
I think it's under main/g

> 
> 4)  How can it be installed? - 
> Will something like (making appropriate substitutions)
> "apt-get install libglib1.3-12xxxx.deb" work?
> If not, do you have a url or pointer to what I'd need to read to learn how
> to use dpkg to do this package install?
>
dpkg -i file.deb

man dpkg

> 
> 5)  How know which package is the correct one I need to dl & install?
> 
> When I do:
> apt-get -s install libkmid
> ... 
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> 
> Sorry, but the following packages have unmet dependencies:
>   libkmid: Depends: libglib1.3-12 (>= 1.3.12) but it is not installable
> 
> That shows ">=".
> 
> That is different from what you said:
> > The problem at that time was that libkmid
> > is dependent explicitly on libglib1.3-12. That's not available any more,
> > being superceded by libglib1.3-13.
> 
> So, if it has been supersceded by 1.3-13, why doesn't apt-get obtain
> 1.3-13, which would satisfy ">= 1.3.12"?  
> - Oh, is this why: the "-13" doesn't refer to the same thing as the ".13"?
> 

Yes, apt sees different packages : libglib1.3-12 and libglib1.3-13 .

 ">=" tells it about a version of a package. 

Apt sees libglib1.3-12_1.3.12-1 and libglib1.3-13_1.3.13-1 , which are
in it's opinion completely different packages.  

> So, is 1.3-13 being required, but is not available yet?
> 
> (Maybe I should try looking into this more deeply using "apt-cache show
> libglib1", or showpkg, or?)

"apt-cache search foo" is a neat way to search for keywords.

> 
> 6)  How would one know one wants kdebase3-audiolibs, not
> kdebase-audiolibs?  Do you have a pointer to something that tells me about
> what kdebase, and kdebase3 are, and how I could determine which I want in
> my case?
> 
> 7)  Since:
> apt-get -s install kdebase3-audiolibs
> Package kdebase3-audiolibs has no available version, but exists in the
> database.
> This typically means that the package was mentioned in a dependency and
> never uploaded, has been obsoleted or is not available with the contents
> of sources.list
> E: Package kdebase3-audiolibs has no installation candidate
> 
> Where do I look next to start tracking this down?
Look on what kde depends (apt-cache show kde is a good way).


And it says : kdebase-audiolibs | kdebase3-audiolibs 
so you can try kdebase-audiolibs instead.  

and don't forget apt-cache  search.

It's easier to just take list of packages on which kde depends and
install them in one big apt-get install .

I hope it helps and I am not too confusing :-)

> 
[snip]
-- 
	GPG key-id: 1024D/DF04A255                 Dmitriy
	AA16 8FAB 74E1 3511 83D0  9F4B F087 CEC9 DF04 A255
	* encrypted personal mail is very much preferred *

Attachment: pgpBCID5Bho01.pgp
Description: PGP signature


Reply to: