[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install kde in Sid fails - depends libkmid... - How fix?

On Sun, Feb 17, 2002 at 01:40:55AM -0800, tluxt2@yahoo.com wrote:
> I just tried a fresh install of Sid & KDE.  Package "kde" refused to
> install, (although "kdebase" did install), because of a couple
> nonessential packages.   How can this be overcome?

I ran into this last weekend. The problem at that time was that libkmid
is dependent explicitly on libglib1.3-12. That's not available any more,
being superceded by libglib1.3-13. What I did was track down a copy of
libglib1.3-12xxxx.deb, and manually install it using dpkg. THEN I
installed libkmid, then I installed KDE.

Fundamentally, when I run into problems like yours in unstable, I simply
try installing down the chain until I find out what the holdup is. If,
for instance, you had followed up your first failure with

apt-get install libkmid

You  would have found the dependency, then tried to install the
libglib1.3-12 and run into the same thing I did.  You'll need, perhaps,
to do the same with the kdebase3-audiolibs (and you do want to track
kdebase3, I'm pretty sure).

Best of luck!


Brian Bilbrey             "The ships hung in the sky in
bilbrey@orbdesigns.com     much the same way that bricks don't."
www.orbdesigns.com            Doug Adams, H2G

Reply to: