[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian woody - Invalid operand errors

Scott Mohnkern wrote:

Michelle Konzack wrote:

Am 2005-08-13 11:44:47, schrieb Scott Mohnkern:
We're seeing something really strange with a relatively new (a couple of

Running vmlinuz-2.2.20-idepci Kernel.

We've replaced the ram, replaced the drives, reinstalled the OS, and are still seing the problem.

I think, you should replace the Kernel.
Nobody use it and it has many BUGs.

We've got another virtually identical server, that's not seeing these

               A server and runnig this Kernel ?

Anyone got any ideas?

Replace the Kernel with a 2.4.27 and if you realy want to run Woody,
get the Kernel-Image from <http://www.backports.org/>.



Thanks, we've tried a couple of kernel updates, and when we reboot after the updater, the machine locks on bootup. I know that from 2.20 to 2.4 they did some major reorganizing of things, and I haven't quite figured out what I'm doing wrong. (We'd been running Sun boxes for 9 years prior to this, and we're porting over to Debian)

I'll keep reading, but if anyone knows what this 2.20 kernel would be working fine in one machine, and not the other, help would be appreciated.


Well, started to work on the upgrade to 2.6.8 on one of the two servers today. Tried two methods, 1 using the .deb file, the other doing a compile.

Using the Deb file, I got a warning about the fact that there was no initrd.img file on the drive. The 2.2 Kernel I has didn't need it.

The compile appeared to run just fine however, on bootup I got a Panic with a "Cannot open root device "301" error.

Reading docs, it talked about making sure that IDE had been enabled when setting the kernel options, which I tunned on the Generic IDE Hard Drive option.

Anyone got an idea?

Running an amd 2.4 motherboard, pretty standard Seagate IDE 80 GB hard drive.


Reply to: