[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: release notes and msgid-previous (was: Re: (forw) Release update: deep freeze, planned dates, and remaining bugs

Thanks for all your help, Jens. :))

On 05/02/2009, at 11:29 PM, Jens Seidel wrote:

On Thu, Feb 05, 2009 at 10:23:23PM +1030, Clytie Siddall wrote:
On 04/02/2009, at 1:04 AM, W. Martin Borgert wrote:
It would really help if the release-notes (and any other document
translations using PO format) used the gettext feature msgid- previous
[1] (as D-I and many debconf files do). This feature makes it much
easier to see what changes have occurred in strings. It's especially
helpful with complex or long strings: documentation files are a
classic case.

Yes, there are two lines in the Makefile starting with UPDATEPO,
of which one is uncommented. Please change this in your local copy.
(We have to support etch, were po4a does not have --previous.)

I've copied the svn-updated release-notes/Makefile into release- notes/

The Makefile should not be copied into vi/. It assumes to be located at the top
level directory of the Release Notes.

Umm... I've left the original Makefile where it is, just made another copy in /vi and modified that. But if I modify the Makefile for the top-level directory, and commit the change, won't it affect all the languages? And if I don't commit the change, it won't affect the files in /vi when po4a is run on the server ?

I'm sure this makes sense, but I just haven't been able to work it out yet. :S

and uncommented (removed #) the UPDATEPO line containing "--
previous". So the next run of po4a (with the next lot of changes, I'm
assuming) will give me msgid-previous? Yay! :D

Since you do not work in a Linux environment and don't have po4a installed you don't have to make anything. The person who calls "make LINGUA=vi updatepo"
should remember it and do it for you.

If I had more concentration [1] right now, I could run po4a on OSX (UNIX). Sorry I don't. I hope things will improve, so I can be more useful, though.

I do have po4a installed, but probably an old version. I can run very basic svn commands now, so with a bit of luck, I'll recover enough concentration to do a little more on the command-line. I'm not happy without the Translate Toolkit [2], either. ;)

The last time I forget it, sorry. But at least I warned you that you worked on old files and tried to reduce the trouble by updating the files immediately. Nevertheless I assume the required changes to resolve these fuzzy states were
only marginal as only a few small paragraphs were affected.

NBD. My fault, really. I probably should have announced my (hopefully ongoing) return to translating Debian files. :D

from Clytie

Vietnamese Free Software Translation Team

[1] http://www.ahummingbirdsguide.com/

[2] http://translate.sourceforge.net/wiki/toolkit/index

Reply to: