[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing on extended partition

O 25/08/21 ás 22:18, Samuel Thibault escribiu:
Parodper, le lun. 23 août 2021 08:40:17 +0200, a ecrit:
O 19/08/21 ás 20:34, Samuel Thibault escribiu:
Tried using «dd bs=512 skip=1 seek=1 conv=notrunc if=debian-hurd.iso
of=/dev/sda8». It still needs MAKEDEV to mount it, and does not recognize
the partition table.

I cannot reproduce the issue. In my test I could was able to just
provide the /dev/hd0s5 path and it'd just work.

Yeah, it is going to be hard to reproduce. After I discovered that the netboot installer (from https://d-i.debian.org/daily-images/hurd-i386/daily/netboot/mini.iso, it was the only ISO in the daily folder) did not need to load from the disk I tried it. I still get the unknown partition table, and doing head /dev/hd0s1 fails with a «Input/Output error». head /dev/hd0 works fine.

* Installer asks for drivers, choose to manually select the drive.
* Then I change to TTY2, cd /dev and ./MAKEDEV hd0s6
This last step was not necessary in QEMU, that is why I was asking.

That shouldn't be necessary at all, /dev is getting filled with device
translator entries during the boot process, see attached snapshot.

I do get the same things on boot (see https://i.imgur.com/XGImhqK.jpg), but
when I try to do «mount -t iso9660 /dev/hd08 /mnt», or even just «head
/dev/hd0», I get a Input/Output error.

Ah, you mean that there really are some existing entries but they don't
work, and the entries created by MAKEDEV happen to seem to work?

About /dev/hd0 itself it's very surprising that it'd get Input/Output
errors since the entry that MAKEDEV create is strictly the same as the
existing one.

As for /dev/hd0s8, d-i indeed uses the parted layer to access the
partition, while MAKEDEV creates an entry that uses the kernel-level
driver for partitions. It is very surprising that the latter would
work better than the former, since only the former is maintained. When
you open your disk with parted from a Linux system, does it complain

It does not, but something interesting is that in GParted sda6 (I had sda6 [ext2 Hurd root], sda7 [swap] and sda8 [iso] in case parted was not able to create partitions) appeared with the same label as sda8. However, after the test above I deleted those partitions and the rror persists.

PD: Is there any way to tell the translators to be more verbose? Something
like 'echo OPTIONS=--verbose >> /etc/translator.conf'?

There is no such global thing since translators are allowed to be
implemented whatever the way they prefer. But you can start translators
by hand to make sure to get their output:

settrans -a /dev/hd0s8 /hurd/storeio -T typed part:8:device:hd0


Tried doing settrans -a /dev/hd0s1 /hurd/storeio -T typed part:1:device:hd0; head /dev/hd0s1 and still getting IO error. The command also ends and does not output any error.

Side note, ls /dev is very slow (after a while I just cancel it), while echo /dev/* is instantaneous.

Reply to: