[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: virtio support

On Tue, 2016-02-09 at 18:12 +0530, Ritesh Raj Sarraf wrote:
> On Tue, 2016-02-09 at 13:22 +0100, Flávio Cruz wrote:
> > > Upon reset, as expected, I ran into file system inconsistency
> > > issue. So
> > > now I had an install that was not bootable.
> > > 
> > > The tricky part is on how to debug such states. At that point,
> when
> > > it
> > > is in boot-up, I do not have a (emergency) shell. The login
> program
> > > just loops and respawns. So, I've not found a way to debug these
> > > problems. My only option is to revert back to my good working
> > > snapshot.
> > I've seen that happen before, where the login program just loops
> > indefinitely. To fix it, and avoid reverting to a snapshot, I
> simply
> > mount the qemu image as a regular partition on the host system and
> > then fsck it. This allows me to boot the Hurd again without any
> > issues.
> Thank you Flavio. Yes. I'll try that next time I run into it.

I think I'm just having a bad time. :-(

rrs@learner:~/.rrs-home/Libvirt-Images$ sudo fdisk -l Hurd.qcow
Disk Hurd.qcow: 3.5 GiB, 3729326592 bytes, 7283841 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
2016-02-09 / 18:55:58 ♒♒♒  ☺    

rrs@learner:~/.rrs-home/Libvirt-Images$ sudo fsck /dev/loop1 fsck from util-linux 2.27.1e2fsck 1.42.13 (17-May-2015)ext2fs_open2: Bad magic number in super-blockfsck.ext2: Superblock invalid, trying backup blocks...fsck.ext2: Bad magic number in super-block while trying to open
The superblock could not be read or does not describe a valid
ext2/ext3/ext4filesystem.  If the device is valid and it really contains an
ext2/ext3/ext4filesystem (and not swap or ufs or something else), then the superblockis corrupt, and you might try running e2fsck with an alternate
superblock:    e2fsck -b 8193 <device> or    e2fsck -b 32768 <device>
2016-02-09 / 18:58:58 ♒♒♒    ☹  => 8  

And I'm very confused because my Hurd install had an ext2 file system
on a partition, and a separate smaller swap partition.

I'm just going to revert back my attempt using VBox for now, to be sure
of what is the actual failure here, on my box.
For completeness of this thread, here's what the prompt looks like once
the file system is not repairable by the boot up scripts.

Ritesh Raj Sarraf
RESEARCHUT - http://www.researchut.com
"Necessity is the mother of invention."

Attachment: Screenshot_Hurd_2016-02-09_19:04:08.png
Description: PNG image

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: