[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Another installation report (quite long)

On Tue, Apr 04, 2000 at 01:05:48AM +0100, Colin Watson wrote:
> I've spent today getting a Hurd system up and running under VMware [1],
> and I've had various problems along the way which I thought I'd share.
> I'm working on a P3-450 with 160Mb of RAM, 48Mb of which is currently
> allocated to the Hurd, and (luckily) IDE disks.

48 MB is enough, however, you must add a swap space, or the Hurd will be
less reliable (don't ask...).If you don't have a partition to spare (it can
be a linux swap, but obviously not the one you already use for the
underlying running linux), you can use a file on disk.

dd if=/dev/zero of=/gnu/swap bs=1024k count=64

And then, in /gnu/boot/servers.boot:
/dev/hd0s2/swap $(add-raw-paging-file)

That's all.
> (By the way, there's a bug in cross-install with respect to the current
> woody archive, as libreadlineg2 is now in oldlibs.)

Jupp, I will fix it now (it was reported a few days ago).
> The first thing I noticed was that, when I use Ctrl-Alt-Esc to get
> VMware to relinquish keyboard focus, or when I hit various other
> modifier-key combinations, I get one of the following errors on my Hurd
> console:
>   kd_setleds1: unexpected state (1)
>   kd_setleds1: unexpected state (2)

Seems to be a Mach thing. You could check the keyboard translation code.
(the Mach console and keyboard codes are a bit weird, and not complete.)
>   hd02: bad access: block=28, count=2, blockend=30, nr_sects
>   end_request: I/O error, dev 03:02, sector 28

Harmless, although it would be nice to have it fixed.
> I tried to run native-install, anyway, and found that it invariably hung
> partway through for no well-determined reason.

Do you remember where?

> The fallback console
> doesn't seem to know about Ctrl-C (can this be fixed?),

I suspect it was already in a state where Ctrl-C didn't work. Or did you
verify that it does not work in general? (The fallback is identical to the
real console, it's just in an unusual place /tmp/console).

> so I'd no way of
> aborting and had to hard-reset the VMware box (which of course left my
> filesystem slightly corrupted, but I don't think it did any harm). The
> second time through it made it to the end,

I think native-install is idempotent. Someone could check this by reading
its code and let me know if he finds a problem with running it several

> but I still have a sense of
> flakiness about the system - it's hung similarly once or twice apart
> from during the initial installation process, I had a "Computer bought
> the farm" during native-install once, and I'm getting the "default
> pager" errors which I've heard are a known problem.

The default pager means that you run out of memory. (Probably a leak
somewhere, but it also happens in unfortunate cases without swap).

> I had problems with ae, too; when I tried to edit /etc/hostname with it
> it refused to write it out with a trailing newline, which led to my
> login banner

Mmmh. I didn't see this before. However, ae sometimes shows a message "write
failed" while it succeeded. And don't use joe, btw. It corrupts files on the

>   dpkg-deb: fgetpos failed

I suppose a bug/missing feature in the isofs translator. It is already
submitted as a regular report.


`Rhubarb is no Egyptian god.' Debian http://www.debian.org Check Key server 
Marcus Brinkmann              GNU    http://www.gnu.org    for public PGP Key 
Marcus.Brinkmann@ruhr-uni-bochum.de,     marcus@gnu.org    PGP Key ID 36E7CD09
http://homepage.ruhr-uni-bochum.de/Marcus.Brinkmann/       brinkmd@debian.org

Reply to: