[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Another installation report (quite long)

Marcus Brinkmann <Marcus.Brinkmann@ruhr-uni-bochum.de> wrote:
>On Tue, Apr 04, 2000 at 01:05:48AM +0100, Colin Watson wrote:
>> I've spent today getting a Hurd system up and running under VMware [1],
>> and I've had various problems along the way which I thought I'd share.
>> I'm working on a P3-450 with 160Mb of RAM, 48Mb of which is currently
>> allocated to the Hurd, and (luckily) IDE disks.
>48 MB is enough, however, you must add a swap space, or the Hurd will be
>less reliable (don't ask...).

Thanks, I hadn't got round to that yet (suppose it should have been the
first thing I did ...). I'll see if that helps.

>> I tried to run native-install, anyway, and found that it invariably hung
>> partway through for no well-determined reason.
>Do you remember where?

Various places: it didn't seem very related to what was actually
happening. Once was while setting up ed, once was while setting up
base-files (just after creating /var/mail), and there was another
occasion as well.

>> The fallback console
>> doesn't seem to know about Ctrl-C (can this be fixed?),
>I suspect it was already in a state where Ctrl-C didn't work. Or did you
>verify that it does not work in general? (The fallback is identical to the
>real console, it's just in an unusual place /tmp/console).

Well, cat<ENTER><Ctrl-C> didn't work, for example, so no it doesn't work
in general ... it seemed fine once I got through the native-install.

>> I had problems with ae, too; when I tried to edit /etc/hostname with it
>> it refused to write it out with a trailing newline, which led to my
>> login banner
>Mmmh. I didn't see this before. However, ae sometimes shows a message "write
>failed" while it succeeded.

I'll see if I can pin this down and make sure it's not just me.

Colin Watson                                           [cjw44@cam.ac.uk]

Reply to: