[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Another installation report (quite long)

I've spent today getting a Hurd system up and running under VMware [1],
and I've had various problems along the way which I thought I'd share.
I'm working on a P3-450 with 160Mb of RAM, 48Mb of which is currently
allocated to the Hurd, and (luckily) IDE disks.

Firstly, for reference and to help anyone else who's trying the same
thing, the installation sequence I used (after several abortive tries)
was as follows:

Download and edit the tools, inc. cross-install;

(By the way, there's a bug in cross-install with respect to the current
woody archive, as libreadlineg2 is now in oldlibs.)

mke2fs -o hurd -L debian-hurd /dev/hda5

(I initially tried to use a VMware "virtual disk", effectively a
filesystem mounted loopback from a file, but I found it to be more
trouble than it was worth as in order to access it in Linux I had to use
the provided vmware-mount.pl which uses the network block device, and I
seemed to be tickling bugs in this which meant that I had to reboot
rather more often than I wanted to.)

mkdir /gnu
mount -t ext2 /dev/hda5 /gnu
./cross-install /gnu
mount -o remount,ro /gnu        (amusing effects without this ...)

I also used grub-boot- from the GNU FTP site. (At least
one of the links I found to this was out of date and wouldn't boot for
me; I believe it was the one from the GNU mirror of Matthew Vernon's
guide, which I was following.)

The first thing I noticed was that, when I use Ctrl-Alt-Esc to get
VMware to relinquish keyboard focus, or when I hit various other
modifier-key combinations, I get one of the following errors on my Hurd

  kd_setleds1: unexpected state (1)
  kd_setleds1: unexpected state (2)

Oh, and during the boot process I get the following disk read error,
which I don't see when booting Linux:

  Partition check (DOS partitions):
   hd0: hd0s1 hd0s2 < hd0s5 hd0s6 >
   hd1: hd1s1 < hd1s5 hd1s6 hd1s7 hd1s8 hd1s9 hd1s10 hd1s11 >
  com0: at atbus0, port = 3f8, spl = 6, pic = 4. (DOS COM1)
  com1: at atbus1, port = 2f8, spl = 6, pic = 3. (DOS COM2)
  com2: at atbus2, port = 3e8, spl = 6, pic = 5. (DOS COM3)
  hd02: bad access: block=28, count=2, blockend=30, nr_sects
  end_request: I/O error, dev 03:02, sector 28

I *think* the extended partition on hd0 is fine. (Shouldn't the "bad
access" message talk about hd0s2, by the way?)

I tried to run native-install, anyway, and found that it invariably hung
partway through for no well-determined reason. The fallback console
doesn't seem to know about Ctrl-C (can this be fixed?), so I'd no way of
aborting and had to hard-reset the VMware box (which of course left my
filesystem slightly corrupted, but I don't think it did any harm). The
second time through it made it to the end, but I still have a sense of
flakiness about the system - it's hung similarly once or twice apart
from during the initial installation process, I had a "Computer bought
the farm" during native-install once, and I'm getting the "default
pager" errors which I've heard are a known problem.

I had problems with ae, too; when I tried to edit /etc/hostname with it
it refused to write it out with a trailing newline, which led to my
login banner and my prompt being corrupted with odd control characters.
This could be a bug in ae rather than the Hurd, though, or even a bug in
me as I don't normally use ae. :)

I can't su:

  cjw44@hurd:~$ su -
  su: cannot set groups: Operation not permitted

Should I be able to? Or is set-id not implemented yet? ('login' works,
though ...)

An odd problem that I've only seen peripherally mentioned before while
trawling through the list archives:

  (with linux-home set as a translator for my Linux /home partition)
  hurd:~# dpkg -i linux-home/cjw44/hurd/zlib1g_1.1.3-5.deb
  dpkg-deb: fgetpos failed
  dpkg: error processing linux-home/cjw44/hurd/zlib1g_1.1.3-5.deb (--install):
   subprocess dpkg-deb --control returned error exit status 2

... but copying it to the Hurd partition and installing it from there
works fine.

Finally, I might be hallucinating here, but when I start up the pfinet
translator on /servers/socket/2 I can't ping Linux, but once I ping the
Hurd from Linux then the reverse direction works fine too.

All that aside (and I'll try to keep reporting bugs, through the Debian
BTS if appropriate) I'm very impressed with the Hurd: it clearly has a
long way to go yet, but I didn't realize it had got so far. Once I get a
development system up and running I might be able to start porting some
packages, with a bit of luck.

[1] I don't like its licence either, but it's the only way I can run the
    Hurd at all at the moment. Someone mentioned Bochs, but while that
    may be open source, its licence is commercial and only allows you a
    30-day trial. As soon as FreeMWare is usable or I have enough money
    for a second computer, I'll switch.

Colin Watson                                           [cjw44@cam.ac.uk]

Reply to: