[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help for mipsel building environment


thank you of your answer, I tried to apply that, but without success:

On Sat, Jun 19, 2010 at 11:35 AM, Neil Williams <codehelp@debian.org> wrote:

> The changes you need are:
> 0. Copy /etc/pdebuild-cross/pdebuild-cross.rc to somewhere.
> Copy /usr/share/multistrap/mipsel.conf alongside it.
> 1. Specify mipsel in the CROSSARCH field in pdebuild-cross.rc and
> change the MULTISTRAPFILE field to specify the
> original /usr/share/multistrap/mipsel.conf file.
> http://pastebin.ca/1886301
> 2. Edit the local mipsel.conf file and add a single line to the
> [General] section: explicitsuite=true
> http://pastebin.ca/1886302

My configuration was yet exactely same that what you propose, but the
line explicitsuite=true

> 3. Make a subdirectory and create your tarball with:
> $ sudo multistrap -f mipsel.conf -d /path/to/subdir/
> 4. Copy or move that tarball into the place specified in
> pdebuild-cross.rc as BASETGZ
> 5. Login to the chroot and tweak the config:
> sudo pbuilder login --configfile pdebuild-cross.rc --save-after-login
> echo dpkg-cross dpkg-cross/default-arch string mipsel | debconf-set-selections
> dpkg-reconfigure dpkg-cross
> (This only needs to be done once. I must admit, I thought I'd got that
> bit working without the hack inside the chroot, that's what the
> CROSSARCH field was meant to do. I'll debug that later - file a bug
> report about that too if you like, in case I run out of time.)
> 6. Now you can copy the config files back into their original locations.
All this procedure work as explained.

I then tried to test my new build environment, for that I downloaded
the squeeze source of the nano package, then I try to build it with
pdebuild-cross. First it failed because the apt database was not up to date.

I eventually found that I can use the ordinary pbuilder command with
the proper configuration

 sudo pbuilder update --configfile /etc/pdebuild-cross/pdebuild-cross.rc

Then I tried to pdebuild-cross nano, the script ran without error, and
produced ...
A package for amd64, the host architecture;

The log is at http://pastebin.ca/1887268

To summarize,
- the script execute the proper:
pdebuild --architecture mipsel --configfile
- It updates local package dependencies
- then execute A00cross-deps-hook to update apt-cache for mipsel
- then use dpkg-buildpackage -us -uc  -rfakeroot without specifying
any architecture

I'm not able to sort out what happen, my knowledge of pbuilder is to shallow.

Can you understand it?

Thanks again for your help


PS: I will report the doc wishes, once I have better understood the
process, some rough edges (like the update problem) appears only when

Reply to: