[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Linux-PC blocked/filtered in the network. (Was: Where do I see the DNS settings used i Lenny)

Today I have tested the network at several schools,
and at the town hall. It is not possible to surf on
www on any of these networks using a PC running
Linux. My conclusion is that there has to be some kind
of filtering of traffic that exclude PC's running Linux.

>From the same PC I can send and receive email,
I can ping and trace (mtr) addresses on www, and
I can view webpages that are on servers on the
inside of the filtering-gateway.

By doing these test I have demonstrated that SLX
is not the problem.  I have also demonstrated for
the admins at the town hall that using  Linux-PC
on a "clean" network, surfing is no problem.

Tomorrow I'm going to visit the network-admins 
at Atea, so that they could see what happens when
a PC running Linux tries to access www.

What kind of things should I test to document, or find
the problems? So far I have just used MTR to document
slow respons, wget --no-proxy to document that
www hangs and ends time out, ifconfig to show NiC
settings, and route...


PS: UmoeIKT is the same company that refused to
turn on IMAP on the exchange servers, resulting in
3 week without mail at our school. All the other
schools had to upgrade Outlook in order to connect
to the new exchange-server with MS MAPI settings.

Den 17.02.11 19.32, skrev Ole-Anders Andreassen:
Ok, I have tried to talk to the folks at Atea, but they tells me that this is a Linux problem.
( Atea is the leading Nordic and Baltic supplier of IT infrastructure with approximately 5,400 employees)

When we moved in to the new school one year ago we had the same problems, the solution was to route our school on the outside of the "gateway-security-filter".
But after an "upgrade" we are forced back, and have to use the same gateway as all the other schools in the region.

Diskless Clients can surf on the Internet, but it is slow. 
The server can surf on the Internet. 
Laptops using Ubuntu linux on 10.0.2-network can't surf on the internet.
Ubuntu PC's can ping adresses on the outside of the filtering-gateway, and skolelinux.org resolves to
It is almost not possible to update Ubuntu PCs
It is not possible to update SLX servers, apt hangs on "waiting for headers...."

At school we have 3 different networks. One for the pupils, one for administration and theachers, and one for art/music-school.
On the two first networks I run slx-servers. The third network is administrated by the admin-staff at the town hall. When i try an Ubuntu PC at this network the same thing happens. I can ping and trace skolelinux.org, and it resolves to But I can't surf the web, and I can't install or update software because of timeout.

All PC's and clients can with no problems view webpages that are on servers on the inside of the filtering-gateway. E.g Sunndal.kommune.no - www.tingvoll.kommune.no, www.kristiansund.kommune.no and so on...

I've tried to use rsync to get the latest DVD, but it is not possible. SSH is also blocked, so I can't use SSH to user.skolinux.no, and I can't update the schools webpage using scp....

This is so fun...


Den 17.02.11 14.30, skrev Klaus Ade Johnstad:
 Torsdag 17. februar 2011 13.01.17 skrev Ole-Anders Andreassen :
Things worked fine until a few days ago, then they changed someting
on the outside of our  network, and I have been told that everything
should be transparent.

Right, honestly, I think you should have a talk with those that changed 
something on the outside of your network, as the cahnage and your 
problem seems to coincide.

Reply to: