[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with Adaptec 2100s

Today I finally managed to install slx 3.0, profile thinclient-server on my Primergy TX200!

It was wiping the disks that solved the issue:-)

I tried once more to use guided partitioning; selected encrypted volumes, and after the wiping had finished I was asked to give the new volume a name.. Which I did not do. Instead I rebooted the server and performed a new install using the automatic partition tool.

Since the install, I have rebooted a couple of times, and it seems to work OK.
Jan Røed from Sunndal ungdomsskole had the same problem and managed to solve it by formatting his disks with NTFS..
It has obviously something to do with filesystems already on the disks.

Thor Hauknes
Løkeberg skole

On 8/6/07, Thor Hauknes <thor.hauknes@loekebergskole.no> wrote:
I have googled a bit and some others have similar problems:

Is the qouted solution below valid on a debian setup?

" Here is what I've found and it works for me.

I have a SuperMicro 6012L-6 with P4DLR+ with Adaptec 2005S.

Installing SuSe 10.0 gives "dpti0: Trying to abort cmd=...".

Here are the workaround steps.

1. After the first reboot go to single user mode. In GUI press F2 and type "single". In text mode press "e", then select "kernel ..." line and press "e" again and type single. Press enter and then "b" to boot.

2. Once at the command prompt create file /etc/sysconfig/hotplug and add this line


Where 0104 is the class of your Adaptec controller.
Run "lspci -mn" to get it. Here is my output.

02:03.0 "Class 0104" "1044" "a511" -r01 "1044" "c032"

Note where it says: "Class 0104".

All this will prevent /etc/init.d/boot.coldplug from hanging when running /etc/hotplug/pci.rc.
Script pci.rc sources /etc/sysconfig/hardware/scripts/functions that in turn sources /etc/sysconfig/hotplug.

3. Now you need to prevent udev from trying to load dpt_i2o module.

Add the following two lines to /etc/hotplug/blacklist.


4. Reboot and continue the installation."

Thor Hauknes

On 8/5/07, Jan Roar Rød < janroed@gmail.com> wrote:
well, I have tried to compile a 2.6.21 kernel, and I got the same error
on the servers with adaptec 2100S.

what I have success with, is to compile a 2.6.18 kernel. in makeconfig I
turn off ALL OTHER adaptec drivermodules, just keep i2o_dpt. then I
compile, and install the kernel. It works well on our servers. No more
superblock error on our servers with adaptec 2100s.

I'm beginning to think that one of the other adaptec kernelmodules that
comes with the etch default kernel conflicts with i2o_dpt.

Debian-edu (skolelinux) RC3 worked almost perfectly on our servers with adaptec 2100S.
we did have some issues with superblock error on /dev/sda1 with RC3 too, but it was usualy fixed
by using a linux-livecd (we used kubuntu). we bootet kubuntu livecd, used qtparted and wiped all partritions
off the disk. then we installed debian-edu (skolelinux) 3.0 Rc3. However on debian-edu (skolelinux) 3.0R0 it does not work doing it that way.

Jan Roar Rød
Sunndal Ungdomsskole

Petter Reinholdtsen wrote:
> On Sun, Aug 05, 2007 at 01:39:10PM +0200, Petter Reinholdtsen wrote:
>> [Thor Hauknes]
>>> I hope this information is useful.
>> It is.  Then I know that the problem is not the content on the disks.
>> Some more googling sent me to SuSe
>> <URL:https://bugzilla.novell.com/show_bug.cgi?id=114718>, claiming
>> this is a kernel bug that has been fixed in later kernels.  I'm not
>> sure which kernel version got the fix included.
> I found it listed in
> <URL: http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.15-rc6 >,
> making me believe this bug was fixed in version 2.6.15, and thus
> before 2.6.18.  I guess we need to keep looking.  This is the patch in question:
>   commit 87d47d0547631e059c308b392cd2423fe9248c93
>   Author: Ben Collins <bcollins@ubuntu.com>
>   Date:   Sat Dec 17 18:39:23 2005 -0800
>       [PATCH] i2o: Do not disable pci device when it's in use
>       When dpt_i2o is loaded first, i2o being loaded would cause it to call
>       pci_device_disable, thus breaking dpt_i2o's use of the device.  Based on
>       similar usage of pci_disable_device in other drivers.
>       Signed-off-by: Ben Collins <bcollins@ubuntu.com>
>       Signed-off-by: Linus Torvalds < torvalds@osdl.org >
> Perhaps this isn't solved yet, and it helps to load i2o before
> dpt_i2o?  Not quite sure how to make that happen in the initrd.
> Perhaps it is enough to edit /target/etc/modules and append this:
>   i2o
>   dpt_i2o
> It will have to be tested. :)
> Happy hacking,
> --
> Petter Reinholdtsen

To UNSUBSCRIBE, email to debian-edu-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: