[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with Adaptec 2100s

Yesterday I tried to install a thinclient server using the netinstall cd.
I got the server up alright, but I got an fsck error message during installation indicating something wrong with the filesystem.

The server is a Fijutsi Siemens Primergy TX-200; a server I believe a lot of schools in Norway use.
>From the information I got from Jan Røed of Sunndal Ungdomsskole, the problem seems to be related to the kernel and the Adaptec 2100s Raidcontroller.
These servers have been used with both Slx 1.0 and 2.0 without problems.
Jans advice would be to compile your own kernel with the i20_dpt enabled, and other raidcontrollers disabled.
I`ve looked into some howtos about this, even tried a bit, but this seems to be beyond my unix skills at the moment.

This behaviour looks a lot like http://bugs.skolelinux.no/show_bug.cgi?id=484

I hope there is a solution for this, at the moment I just have to wait for this to be fixed in the next release. As school is starting up very soon, we might have to stick with Sarge until then.

Output of dmesg is here:
Below is the output av /var/log/fsck/checkfs

Thor Hauknes
Løkeberg skole

Log of fsck -C -R -A -a
Thu Aug  2 13:38:23 2007

fsck 1.40-WIP (14-Nov-2006)
fsck.ext3: No such file or directory while trying to open /dev/sda1
The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

/dev/mapper/vg_system-opt: clean, 26719/650240 files, 180827/1300480 blocks
/dev/mapper/vg_system-usr: clean, 131124/650240 files, 765718/1300480 blocks
/dev/mapper/vg_system-var: clean, 7423/625248 files, 257955/1250304 blocks
+ltsp+swapfiles: clean, 11/375360 files, 29294/750592 blocks
fsck died with exit status 8

Reply to: