[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with Adaptec 2100s

well, I have tried to compile a 2.6.21 kernel, and I got the same error on the servers with adaptec 2100S.

what I have success with, is to compile a 2.6.18 kernel. in makeconfig I
turn off ALL OTHER adaptec drivermodules, just keep i2o_dpt. then I
compile, and install the kernel. It works well on our servers. No more
superblock error on our servers with adaptec 2100s.

I'm beginning to think that one of the other adaptec kernelmodules that
comes with the etch default kernel conflicts with i2o_dpt.

Debian-edu (skolelinux) RC3 worked almost perfectly on our servers with adaptec 2100S.
we did have some issues with superblock error on /dev/sda1 with RC3 too, but it was usualy fixed
by using a linux-livecd (we used kubuntu). we bootet kubuntu livecd, used qtparted and wiped all partritions off the disk. then we installed debian-edu (skolelinux) 3.0 Rc3. However on debian-edu (skolelinux) 3.0R0 it does not work doing it that way.

Jan Roar Rød
Sunndal Ungdomsskole

Petter Reinholdtsen wrote:
On Sun, Aug 05, 2007 at 01:39:10PM +0200, Petter Reinholdtsen wrote:
[Thor Hauknes]
I hope this information is useful.
It is.  Then I know that the problem is not the content on the disks.

Some more googling sent me to SuSe
<URL:https://bugzilla.novell.com/show_bug.cgi?id=114718>, claiming
this is a kernel bug that has been fixed in later kernels.  I'm not
sure which kernel version got the fix included.

I found it listed in
making me believe this bug was fixed in version 2.6.15, and thus
before 2.6.18.  I guess we need to keep looking.  This is the patch in question:

  commit 87d47d0547631e059c308b392cd2423fe9248c93
  Author: Ben Collins <bcollins@ubuntu.com>
  Date:   Sat Dec 17 18:39:23 2005 -0800

      [PATCH] i2o: Do not disable pci device when it's in use
When dpt_i2o is loaded first, i2o being loaded would cause it to call
      pci_device_disable, thus breaking dpt_i2o's use of the device.  Based on
      similar usage of pci_disable_device in other drivers.
Signed-off-by: Ben Collins <bcollins@ubuntu.com>
      Signed-off-by: Linus Torvalds <torvalds@osdl.org>

Perhaps this isn't solved yet, and it helps to load i2o before
dpt_i2o?  Not quite sure how to make that happen in the initrd.
Perhaps it is enough to edit /target/etc/modules and append this:


It will have to be tested. :)

Happy hacking,
Petter Reinholdtsen

Reply to: