[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Buildd & binary-indep

* Joachim Breitner <nomeata@debian.org> [100926 21:45]:
> Let me rephrase Reinhard:
> what's the problem with requiring the build-arch and build-indep target
> for all packages in debian after squeeze release?

Most packages do not have build-arch and build-indep. (Mostly due to
dh_make not including them for single packages).

So without a heuristic whether it is available, one would have almost
instantly a large part of the archive (I guess something between 20% and 80%)

I personally am a big fan of just using Standards-Version as indicator.
Make a new policy 4.0.0 that says every package with Standards-Version
>= 4 is required to have build-indep and build-arch.
Then one can either change dpkg-buildpackage and other tools to call
build-arch directly if that Standards-Version is found, or one at least
has a good way to make this required without most packages being
instantly rc-buggy, as people just needs to add a
"build-arch build-indep: build" to their rules file if increasing the
Standards-Version and they do not support it yet.

But this whole discussion got boring something like 10 years ago. It's
a shame there is still no proper solution for that now.

	Bernhard R. Link

Reply to: