[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: uninstallable despite satisfying dependencies

On Tue, Jul 10, 2007 at 11:03:11PM -0500, Steve M. Robbins wrote:
> > This looks like ipe is misusing freetype, if it refuses to work with newer
> > versions when these versions are ABI-compatible.

> The short answer is -- this is the claim of Ipe's author, not me --
> libfreetype frequently breaks ABI compatibility even with
> minor-version updates.  So ipe has an explicit check of the freetype
> version.

Ok, well this is (currently) false.  Unless ipe is using symbols that are
not part of the exported freetype headers, libfreetype6 has not had any
(unreversed) ABI changes since 2003, covering two major revisions.  I know
because I had a panic attack two years ago when 2.1.10 first came out and
broke the ABI relative to 2.1.7. ;)

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: