[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: uninstallable despite satisfying dependencies

On Tue, Jul 10, 2007 at 08:40:31PM -0700, Steve Langasek wrote:
> Hi Steve,
> On Tue, Jul 10, 2007 at 10:03:16PM -0500, Steve M. Robbins wrote:
> > How do I debug this situation: ipe won't install, yet I have the 
> > dependencies that "apt-get install" complains about.
> > Below, you will see that my attempt to install libipe1c2a claims to
> > have three unmet dependencies.  However, as you see by "dpkg --list",
> > I *do* have these three packages at a version that seemingly satisfies
> > the dependencies.  
> > What gives?
> Hmm, I was all ready to file an RC bug about this, only to find that you're
> the maintainer... :)
> Can you explain why libipe1c2a gives the behavior described in bug #369244?

Ah, yes.  I added a Conflicts: libfreetype6 (>= 2.2.2) to libipe1c2a 
and forgot about it :-/

OK.  That explains my problem: faulty memory.

> This looks like ipe is misusing freetype, if it refuses to work with newer
> versions when these versions are ABI-compatible.

The short answer is -- this is the claim of Ipe's author, not me --
libfreetype frequently breaks ABI compatibility even with
minor-version updates.  So ipe has an explicit check of the freetype

Thanks Steve,

Attachment: signature.asc
Description: Digital signature

Reply to: