[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

uninstallable despite satisfying dependencies


How do I debug this situation: ipe won't install, yet I have the 
dependencies that "apt-get install" complains about.

Below, you will see that my attempt to install libipe1c2a claims to
have three unmet dependencies.  However, as you see by "dpkg --list",
I *do* have these three packages at a version that seemingly satisfies
the dependencies.  

What gives?

root@riemann{~}apt-get install libipe1c2a
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libipe1c2a: Depends: libfreetype6 (>= 2.2) but it is not going to be installed
              Depends: libqt4-core (>= 4.2.3) but it is not going to be installed
              Depends: libqt4-gui (>= 4.2.3) but it is not going to be installed
E: Broken packages

root@riemann{~}dpkg --list libfreetype6 libqt4-core libqt4-gui
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                 Version              Description
ii  libfreetype6         2.3.5-1              FreeType 2 font engine, shared library files
ii  libqt4-core          4.3.0-2+b1           Qt 4 core non-GUI functionality runtime library
ii  libqt4-gui           4.3.0-2+b1           Qt 4 core GUI functionality runtime library


Attachment: signature.asc
Description: Digital signature

Reply to: