[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: how to ask for packages rebuilding

Sven Luther <sven.luther@wanadoo.fr> writes:

> On Sun, Oct 19, 2003 at 10:13:06PM +0200, Wouter Verhelst wrote:
> > These all boil down to the same problem: ocaml was upgraded to
> > ocaml-3.07, while the packages that were available at the time depended
> > on ocaml-3.06-1. Since that doesn't exist anymore, they'll never become
> > needs-build again. Under normal circumstances we find such things
> > ourselves, but since we've got quite some backlog currently...
> No, not exactly. The problem is that ocaml 3.07 is available, and ocaml
> 3.06-1 is no more, but the older libraries depended on ocaml 3.06-1,
> while the rebuilt ones depend on ocaml 3.07. This mean that the
> libraries need to be rebuilt in build-depend order, not all together, or
> there will always be build problems. Example with ocaml, lablgl and
> lablgtk, which i maintain :

The change in ocaml results in a change in ABI. You should increase
the so-names so to speak. Thats the same problem as the gcc-3.2
transition or the libc6 transition. Or not?

Seems to be a common problem with ocaml so you might want to think
about something there.


PS: If you give me a list of packages I can run them throught my m68k
buildd in that order and let you sponsor the uploads.

Reply to: