[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gcc 3.2 transition in unstable


> I object to changing the build-essential package.

Me too; Depending on version x and conflicting with all other versions
will no longer work, as you would have to remove build-essential
(Especially the autobuilders will be confused, I think).

> If your package build-depends on g++-3.2 in the sense that it should *not*
> be compiled using any other g++ compiler, you should add a build-depends
> on g++-3.2.

Maybe the g++ packages should "Provides:" their ABI version, so you can
depend on ABI versions?


GPG Fingerprint: 040E B5F7 84F1 4FBC CEAD  ADC6 18A0 CC8D 5706 A4B4

Attachment: pgpNBaMdFLsvc.pgp
Description: PGP signature

Reply to: