[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libgal sonames

On Sat, Sep 01, 2001 at 11:25:32AM -0500, Colin Watson wrote:
> On Sat, Sep 01, 2001 at 05:23:03PM +0200, Rodrigo Moya wrote:
> > The only problem I can see is with the -dev packages, which may need
> > some work to allow different versions to be installed.
> That's OK. We often only support one version of -dev packages, so that
> people don't build against soon-to-be-obsolete versions by accident.

It becomes problem if the versions are not source compatible, however.
Then packages become unbuildable every time we release a new libgal
version (and update the single libgal-dev).

It may be better to have packages that link with libgal (other than
evolution and gnumeric) link statically instead of dynamically.
This would be a workaround until libgal stabilizes.  Presumably it
will stabilize at some point -- either that, or someone will take
the most useful parts of libgal and give them a stable interface
in another library.  There's obviously enough need for what libgal
provides, otherwise there wouldn't be so many packages using it now.

Richard Braakman
Will write free software for money.
See http://www.xs4all.nl/~dark/resume.html

Reply to: