[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Request for package: libgtkxmhtml-nognome

Hi, folks. Recently, I've gotten a bug report on GIMP that it's
missing the help browser. This is because I don't have the
package libgtkxmhtml-dev installed, which is the widget set
GIMP uses for its help browser.

However, libgtkxmhtml-dev depends on the *entire* set of GNOME
libraries being installed, which is far too big of a requirement
for a simple help browser:

gilgamesh:~# apt-get install libgtkxmhtml-dev
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  gdk-imlib-dev gdk-imlib1 gnome-bin gnome-libs-data imlib-base libart-dev
  libart2 libaudiofile-dev libesd0 libesd0-dev libgnome-dev libgnome32
  libgnomesupport0 libgnomeui32 libgnorba-dev libgnorba27 libgnorbagtk0
  libgtkxmhtml1 liborbit-dev liborbit0 libpng2 libpng2-dev orbit zlib1g
The following NEW packages will be installed:
  gdk-imlib-dev libart-dev libaudiofile-dev libesd0-dev libgnome-dev
  libgnorba-dev libgtkxmhtml-dev liborbit-dev
18 packages upgraded, 8 newly installed, 0 to remove and 444 not upgraded.
Need to get 3512kB of archives. After unpacking 6278kB will be used.
Do you want to continue? [Y/n]

This is *NOT GOOD*. I don't want to foist all these extra
dependancies onto the poor GIMP users; it's massive enough
as it is!

Fortunately, there is an alternative gtkxmhtml library *without*
GNOME available:


It shares the same name as the regular gtkxmhtml library, but the
README says that the unneeded GNOME dependancies have been ripped out.

If this package could be created, I'd be very happy. :) I don't
have enough time to maintain yet another package, so hopefully
either the current libgtkxmhtml-dev package maintainer can
package it, or someone else can.

Until then, GIMP will be help-less. :)


Brought to you by the letters J and D and the number 18.
"A yonker is a young man."
Debian GNU/Linux maintainer of Gimp and GTK+ -- http://www.debian.org/

Reply to: