[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: recompile needed for xlib6g (>= 3.3.5-1) instead of (>= ?

On Fri, 1 Oct 1999, Peter S Galbraith wrote:

> [posted this to -mentors 40 hours ago without an answer, so
>  perhaps I'll try -devel instead]
> I recently uploaded i386 packages that were build on a slink system
> upgraded to potato's libc6 and C compilers (everything else is
> slink).  These packages (xcolmix and xplot) have this depends
> line:
> Depends: libc6 (>= 2.1), libforms0.88, xlib6g (>=
> Now I built an all-potato chroot environment and notice that the potato
> xlib6g-dev package creates a depency line:
> Depends: libc6 (>= 2.1), libforms0.88, xlib6g (>= 3.3.5-1)
> Should I rebuild the i386 binaries with the new xlib6g-dev
> and upload them with .0.1 version number suffix?  Or perhaps it
> doesn't matter?

As far as xlib6g is concerned, I don't think it does matter.

As a general rule, as long as you can run the result in potato without
using oldlibs packages, it should be fine. [ Personal note: Most of the
packages I maintain depend on libc6 and nothing more. For this reason I
have not upgraded to potato yet. This way my uploads are usable by both
slink and potato users ].

BTW: If libforms0.88 is actually the "current" libforms in potato, then
you could have even avoided completely the upgrade of libc6 and compilers.
It seems your package should run ok on a potato machine even if it was
compiled on a slink system.


 "93ae05efde18fe439546b944aa06d657" (a truly random sig)

Reply to: