[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: recompile needed for xlib6g (>= 3.3.5-1) instead of (>= ?

Santiago Vila wrote:

> I wrote
> > I recently uploaded i386 packages that were build on a slink system
> > upgraded to potato's libc6 and C compilers (everything else is
> > slink).  These packages (xcolmix and xplot) have this depends
> > line:
> > 
> > Depends: libc6 (>= 2.1), libforms0.88, xlib6g (>=
> > 
> > Now I built an all-potato chroot environment and notice that the potato
> > xlib6g-dev package creates a depency line:
> > 
> > Depends: libc6 (>= 2.1), libforms0.88, xlib6g (>= 3.3.5-1)
> > 
> > Should I rebuild the i386 binaries with the new xlib6g-dev
> > and upload them with .0.1 version number suffix?  Or perhaps it
> > doesn't matter?
> As far as xlib6g is concerned, I don't think it does matter.
> As a general rule, as long as you can run the result in potato without
> using oldlibs packages, it should be fine. 

Okay, I'm just cautious about `should run'.  I guess I compiled
agaisnt glib2.1 such that any problems that might crop up would
be found and fixed before the freeze.

> BTW: If libforms0.88 is actually the "current" libforms in potato, then
> you could have even avoided completely the upgrade of libc6 and compilers.
> It seems your package should run ok on a potato machine even if it was
> compiled on a slink system.

libforms0.88 was the "current" libforms in potato when I posted
this, but now it's libforms0.89 but that is drop in compatible
with 0.88.  In fact the 0.89 packages creates the compatibility

./usr/X11R6/lib/libforms.so.0.88  -> libforms.so.0.89

so recompiles against libforms.so.0.89 aren't strictly necessary.

Thanks for your answer.

Peter Galbraith, research scientist          <GalbraithP@dfo-mpo.gc.ca>
    6623'rd GNU/Linux user at the Counter - http://counter.li.org/ 

Reply to: