[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gdk-imlib needs imlib-dev to work

Ossama Othman <othman@cs.wustl.edu> writes:

> I just got a bug report about gdk-imlib needing the `.so' links I added to
> imlib-dev (they were missing) in order for gnome-panel to work.  I tried
> Electric Eyes and got the same problem, hence all gdk-imlib dependent
> packages will probably need imlib-dev installed before they will work
> (i.e. load images using gdk-imlib).
> I don't understand why a gdk-imlib dependent package would need the `.so'
> links, especially since the imlib-dev-1.9.2 package didn't have the 
> individual image format library `.so' links that I added to the
> imlib-1.9.3 packages.

It shouldn't need the '.so' files.  Those should only be in the -dev

Linking is based on the SONAME fields:

$ objdump --private-headers /usr/bin/panel | grep imlib 
  NEEDED      libgdk_imlib.so.1

So ld.so will look for /usr/lib/libgdk_imlib.so.1 (which should be a
symlink).  The /usr/lib/libgdk_imlib.so symlink is only for compiling.

Check the SONAME in your libraries.  I haven't upgraded yet, so here's
what the old library used to say:

$ objdump --private-headers /usr/lib/libgdk_imlib.so | grep SONAME
  SONAME      libgdk_imlib.so.1

If it just says "libgdk_imlib.so" (without the version number), then
that would create problems for anybody developing with that library.

I'll try upgrading in the next few hours to see what's up.  I'm
somewhat bandwidth limited at the moment.


 - Jim

Reply to: