[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ERROR: missing required packages from profile default: simple-cdd-profiles

vagrant@freegeek.org a écrit :
On Tue, Mar 11, 2008 at 09:39:29AM +0100, Alain wrote:
Well, I followed your advice and tried to make a "simple" install from the current Debian repository:
I created a profiles/KDEPROFILE.packages containing the following lines:
And a profiles/KDEPROFILE.preseed containing:
d-i debian-installer/locale string fr_FR
d-i console-keymaps-at/keymap select fr

these two are handled by the commandline options which you included
below (--locale and --keyboard) ... specifying them in the preseed file
won't work- just use the commandline, or specify in


d-i clok-setup/utc boolean true
d-i time/zone string Europe/Paris
d-i pkgsel/include string standard kde-desktop
d-i pkgsel/include string kde-i18n-fr

specifying a question twice will not work... it will select one or the
other, but not both.

also, simple-cdd makes no attempt to include packages specified with
this question. best to add them to profiles/KDEPROFILE.packages.

d-i finish-install/reboot_in_progress note

I then launched the following command:
build-simple-cdd --locale fr_FR --keyboard fr-latin1  --profiles KDEPROFILE
(I didn't really understood the meaning of the --profiles-udeb option)

the --profiles-udeb-dist option is merely to pull the
simple-cdd-profiles udeb, which is what handles all the simple-cdd stuff
in debian-installer. because simple-cdd wasn't included in etch, you
need to get the simple-cdd-profiles udeb from sid or lenny. if it's
already in the mirror that simple-cdd generates from a previous run,
then you don't actually need to specify it again.
First strange behaviour:
I didn't say anything about partitionning, but the install only asks me while partitionning is already finished.

yes, profiles/default.preseed has some automatic partitioning selected
by default, but still asks the question before it does anything

Install seems to succeed, but when my PC reboots, I see the message: "Not starting internet superserver: no services enabled". And of course, kdm wasn't launched.

it doesn't appear that the packages you selected in
profiles/KDEPROFILE.packages has anything that depends on kdm, so kdm is
not likely present on your CD image.

live well,
Hi Vagrant,

Thanks for your answer. I didn't reply sooner because I wasn't at my office yesterday. Well, I tried to apply all your advices and it seems to work much more better. Bu I still have a problem : kdm starts, but my machine remains in console mode.
In /var/log/syslog, I see that X server dies.
When I try to run dpkg-reconfigure xserver-xorg, it says that xserver-xorg was not installed.
(I was a little bit surprised not to be asked about display configuration).
I asked to install this package, and added it to my profile/KDEPROFILE.packages and profile/KDEPROFILE.preseed.
So, where is the mistake ?


Is there a place where I could find a more detailed documentation about this tools, in order not to annoy the whole list with such newbies questions ?


Reply to: