[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ERROR: missing required packages from profile default: simple-cdd-profiles

vagrant@freegeek.org a écrit :
On Mon, Mar 10, 2008 at 11:14:50AM +0100, Alain wrote:
Jonas Smedegaard a écrit :
On Mon, Mar 10, 2008 at 10:40:41AM +0100, Alain wrote:
vagrant@freegeek.org a écrit :

and just a little reminder, simple-cdd tends to work better the more you stick within debian.

I want to build a so old distro because I have tu use a package (libsnmp-perl) that disapeared from debian repository after that 2005/10/16/ ...

it seems like libsnmp-perl *is* in debian etch, lenny and sid:

libsnmp-perl | 5.2.3-7etch2 | stable libsnmp-perl | 5.4.1~dfsg-6 | testing libsnmp-perl | 5.4.1~dfsg-6 | unstable
is there something wrong with the version in etch?

Wouldn't it then make more sense to "forwardport" that package: Recompile it on a current distro?

Maybe, but it so seemed easier to build a customized distro so I tried ...
In fact, I have to provide a CD or DVD containing all necessary packages to rebuild our source code. This CD has to enable installing a PC without any network access to ensure all packages are on it. So I thought I could build a customized CD with the needed packages, and pressed to make it easier.
But I'm workin on it since 4 weeks and I still have nothing to show :-(

i heartily agree with jonas here- probably easiest to build an etch CD
and adding custom package versions for the few packages you need.

much easier to build and maintain the few customizations you're making
than it is to make an entire distro based on versions of software that
were never part of a stable release.
Well, I followed your advice and tried to make a "simple" install from the current Debian repository:
I created a profiles/KDEPROFILE.packages containing the following lines:
And a profiles/KDEPROFILE.preseed containing:
d-i debian-installer/locale string fr_FR
d-i console-keymaps-at/keymap select fr
d-i clok-setup/utc boolean true
d-i time/zone string Europe/Paris
d-i pkgsel/include string standard kde-desktop
d-i pkgsel/include string kde-i18n-fr
d-i finish-install/reboot_in_progress note

I then launched the following command:
build-simple-cdd --locale fr_FR --keyboard fr-latin1  --profiles KDEPROFILE
(I didn't really understood the meaning of the --profiles-udeb option)

First strange behaviour:
I didn't say anything about partitionning, but the install only asks me while partitionning is already finished. Install seems to succeed, but when my PC reboots, I see the message: "Not starting internet superserver: no services enabled". And of course, kdm wasn't launched.
Any idea ?
live well,

p.s. please do not CC me, i read the list
Oups, sorry


Reply to: