[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-10.2.0-amd64-DVD-{12,14,15}.iso (and.jigdo)

On Tue, Dec 10, 2019 at 08:38:43PM -0700, David Stepaniak wrote:
>Hi Steve,
>I tried the attached 'jigdo-lite' script (renamed 'jigdo-lite.steve') on my
>Cygwin/Windows  home
>PC, but am getting
>$ /home/David/jigdo-bin/jigdo-lite.steve
>/home/David/jigdo-bin/jigdo-lite.steve: line 7: $'\r': command not found
>/home/David/jigdo-bin/jigdo-lite.steve: line 13: $'\r': command not found
>/home/David/jigdo-bin/jigdo-lite.steve: line 17: $'\r': command not found
>': not a valid identifierdo-lite.steve: line 18: unset: `GREP_OPTIONS
>/home/David/jigdo-bin/jigdo-lite.steve: line 19: $'\r': command not found
>/home/David/jigdo-bin/jigdo-lite.steve: line 54: syntax error near unexpected
>token `$'{\r''
>'home/David/jigdo-bin/jigdo-lite.steve: line 54: `isURI() {

Oh, argh. That looks like line endings problems. It worked for me here
directly on a test Windows VM. Maybe your Cygwin setup is confused
here or something? I've just checked what I sent you and there are no
'\r' characters anywhere.

>I tried to track down any un-escaped special character, or anything
>that might trigger this set of errors, due to perhaps a script that
>was corrupted in transit. No luck.
>Anyway, following up on your previous comments, I relocated the
>jigdo-bin directory to a location with the shortest absolute path
>possible, then re-ran the original 'jigdo-lite' script to download
>isos in a working directory with another short as possible absolute
>path.  This time, isos 12, 14, and 15 were downloaded just fine.


>Sorry if any idiosyncrasies of my PC setup, or something I missed completely,
>caused you and the CD team to spend too much time on a wild goose chase.

No, thanks for reporting - it's clearly a problem that I hadn't seen
before and it's a subtle failure mode.

>Now that I have a complete set of DVD's, I am excited to install
>Debian 10.2.0 on a new laptop.

Yay! Have fun with it :-)

Steve McIntyre, Cambridge, UK.                                steve@einval.com
We don't need no education.
We don't need no thought control.

Reply to: